summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-11-20 02:04:49 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-11-20 02:04:49 +0100
commit387ccd90d2984288bf8de2af63613d16226c5e23 (patch)
tree411fe10b93caa1c5f484bc3dde1c48f16a09e80a /app-text/cmark
parentdev-libs/intel-compute-runtime: bump to version 21.45.21574 (diff)
downloadgentoo-387ccd90d2984288bf8de2af63613d16226c5e23.tar.gz
gentoo-387ccd90d2984288bf8de2af63613d16226c5e23.tar.bz2
gentoo-387ccd90d2984288bf8de2af63613d16226c5e23.zip
app-text/cmark: drop old version
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-text/cmark')
-rw-r--r--app-text/cmark/Manifest1
-rw-r--r--app-text/cmark/cmark-0.29.0.ebuild38
-rw-r--r--app-text/cmark/files/cmark-0.29.0-python38_tests.patch31
3 files changed, 0 insertions, 70 deletions
diff --git a/app-text/cmark/Manifest b/app-text/cmark/Manifest
index f6800339eee2..d5eca9eb40ab 100644
--- a/app-text/cmark/Manifest
+++ b/app-text/cmark/Manifest
@@ -1,2 +1 @@
-DIST cmark-0.29.0.tar.gz 234545 BLAKE2B 1571cdf08f85142ff790db811b7973f2d95a7b1c8669af467cbeac1ad0907826a46f7e0e3ba717ba677746406f8372e40b9878f7810d317fa3c0e14db06dc8fb SHA512 06eb110cfd90c9e980c022b7588e28864d15a4da5d07d61ad4b27c6de47367492b9e58e9434e62b07517aa6dc484f17af13916808be3188f38c37d20cbf33112
DIST cmark-0.30.2.tar.gz 246033 BLAKE2B 487f5adf47afdd4133e16b6cca1403cd555f8722b47c423960909de73aacac1d0f8b16311f6d5349addb5f03a86562545bb2ec80771b822bb8e5b82816375124 SHA512 aaa9b2103cf89c522f9b42a2b43c07ecf75e07eb42214c0be5de17682ea1faf9c85e3dd28fe91d446b69a34f9980bcab6e276a99b42540c40c9ee1481b3a0d17
diff --git a/app-text/cmark/cmark-0.29.0.ebuild b/app-text/cmark/cmark-0.29.0.ebuild
deleted file mode 100644
index a1db9210003d..000000000000
--- a/app-text/cmark/cmark-0.29.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit cmake python-any-r1
-
-DESCRIPTION="CommonMark parsing and rendering library and program in C"
-HOMEPAGE="https://github.com/commonmark/cmark"
-SRC_URI="https://github.com/commonmark/cmark/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0/0.29.0"
-KEYWORDS="amd64 ppc ppc64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( ${PYTHON_DEPS} )"
-
-PATCHES=(
- "${FILESDIR}/${P}-python38_tests.patch"
-)
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- -DCMARK_LIB_FUZZER=OFF
- -DCMARK_SHARED=ON
- -DCMARK_STATIC=OFF
- -DCMARK_TESTS="$(usex test)"
- )
- cmake_src_configure
-}
diff --git a/app-text/cmark/files/cmark-0.29.0-python38_tests.patch b/app-text/cmark/files/cmark-0.29.0-python38_tests.patch
deleted file mode 100644
index 13cd71815941..000000000000
--- a/app-text/cmark/files/cmark-0.29.0-python38_tests.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 92697d564042d5b914048e087e4274c3c71e0055 Mon Sep 17 00:00:00 2001
-From: Christopher Fujino <christopherfujino@gmail.com>
-Date: Sun, 12 Jul 2020 16:11:42 -0700
-Subject: [PATCH] replace cgi.escape with html.escape (#656)
-
----
- test/normalize.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/test/normalize.py b/test/normalize.py
-index 6073bf01..f8ece18d 100644
---- a/test/normalize.py
-+++ b/test/normalize.py
-@@ -13,7 +13,7 @@ class HTMLParseError(Exception):
- from html.entities import name2codepoint
- import sys
- import re
--import cgi
-+import html
-
- # Normalization code, adapted from
- # https://github.com/karlcow/markdown-testsuite/
-@@ -66,7 +66,7 @@ def handle_starttag(self, tag, attrs):
- self.output += ("=" + '"' +
- urllib.quote(urllib.unquote(v), safe='/') + '"')
- elif v != None:
-- self.output += ("=" + '"' + cgi.escape(v,quote=True) + '"')
-+ self.output += ("=" + '"' + html.escape(v,quote=True) + '"')
- self.output += ">"
- self.last_tag = tag
- self.last = "starttag"