summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2017-11-30 10:35:52 +0500
committerPatrice Clement <monsieurp@gentoo.org>2017-12-01 22:23:10 +0100
commit3fa77059525b0b22a5045963f5b1e39096f4c658 (patch)
tree3c0e08b287b63775142b33daf9d4f4e24d449132 /app-text/cmark
parentapp-text/cmark: remove old version. (diff)
downloadgentoo-3fa77059525b0b22a5045963f5b1e39096f4c658.tar.gz
gentoo-3fa77059525b0b22a5045963f5b1e39096f4c658.tar.bz2
gentoo-3fa77059525b0b22a5045963f5b1e39096f4c658.zip
app-text/cmark: version bump to 0.28.3.
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-text/cmark')
-rw-r--r--app-text/cmark/Manifest1
-rw-r--r--app-text/cmark/cmark-0.28.3.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-text/cmark/Manifest b/app-text/cmark/Manifest
index 4a838e6d2471..975326d4c52a 100644
--- a/app-text/cmark/Manifest
+++ b/app-text/cmark/Manifest
@@ -1 +1,2 @@
DIST cmark-0.28.0.tar.gz 228973 BLAKE2B e0f42a7a5929eb8fb7a2fb9405372d626b2fea5f895b9320a28629022a8280d01af67e8e13101565ce86a2dbc4b8191eb461e70e45e7fa33c72b8e8266c2ee78 SHA512 86aeb42f17440c8e743057851bc3cee9ed4b3fa27dacc37d6af54dee7739210a712020e59c102ed1852b7c3f904881cb4e9b80ea475772095514c4025284cbb6
+DIST cmark-0.28.3.tar.gz 229391 BLAKE2B b235d3dd8ed9b83d8fd6ec495d311bed854ad61d28e5a5087f40f7e512977892fcdff7c51e8683db87e0ee8e5e73338fe11b8829e70c6f07c59e917a8b7268cc SHA512 409105a3228a8ae22ba6acf95cd99bc9a2c20f8603aa0e803a33172eb6ef53f80f8f0262d2258b77f9fd6e1f2e9017a6c906b88f761e053c09ef88c9ffab7d29
diff --git a/app-text/cmark/cmark-0.28.3.ebuild b/app-text/cmark/cmark-0.28.3.ebuild
new file mode 100644
index 000000000000..55850c46f6d4
--- /dev/null
+++ b/app-text/cmark/cmark-0.28.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit cmake-utils python-any-r1
+
+DESCRIPTION="CommonMark parsing and rendering library and program in C"
+HOMEPAGE="https://github.com/commonmark/cmark"
+SRC_URI="https://github.com/commonmark/cmark/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMARK_LIB_FUZZER=OFF
+ -DCMARK_SHARED=ON
+ -DCMARK_STATIC=OFF
+ -DCMARK_TESTS="$(usex test)"
+ )
+ cmake-utils_src_configure
+}