summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2019-05-13 20:29:42 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-15 13:33:16 +0200
commit482e0900efe29e4099663249a417af44159d82cc (patch)
tree49e8129b8f2663eba95d1fd9a0b79a5ec79d0393 /app-text/cmark
parentnet-im/skypeforlinux: Drop old (diff)
downloadgentoo-482e0900efe29e4099663249a417af44159d82cc.tar.gz
gentoo-482e0900efe29e4099663249a417af44159d82cc.tar.bz2
gentoo-482e0900efe29e4099663249a417af44159d82cc.zip
app-text/cmark: bump to 0.29.0 (#685126)
Version bump to 0.29.0 Closes: https://bugs.gentoo.org/685126 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Package-Manager: Portage-2.3.62, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/11984 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text/cmark')
-rw-r--r--app-text/cmark/Manifest1
-rw-r--r--app-text/cmark/cmark-0.29.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-text/cmark/Manifest b/app-text/cmark/Manifest
index d6f50e153e27..3f5f31c3c583 100644
--- a/app-text/cmark/Manifest
+++ b/app-text/cmark/Manifest
@@ -1 +1,2 @@
DIST cmark-0.28.3.tar.gz 229391 BLAKE2B b235d3dd8ed9b83d8fd6ec495d311bed854ad61d28e5a5087f40f7e512977892fcdff7c51e8683db87e0ee8e5e73338fe11b8829e70c6f07c59e917a8b7268cc SHA512 409105a3228a8ae22ba6acf95cd99bc9a2c20f8603aa0e803a33172eb6ef53f80f8f0262d2258b77f9fd6e1f2e9017a6c906b88f761e053c09ef88c9ffab7d29
+DIST cmark-0.29.0.tar.gz 234545 BLAKE2B 1571cdf08f85142ff790db811b7973f2d95a7b1c8669af467cbeac1ad0907826a46f7e0e3ba717ba677746406f8372e40b9878f7810d317fa3c0e14db06dc8fb SHA512 06eb110cfd90c9e980c022b7588e28864d15a4da5d07d61ad4b27c6de47367492b9e58e9434e62b07517aa6dc484f17af13916808be3188f38c37d20cbf33112
diff --git a/app-text/cmark/cmark-0.29.0.ebuild b/app-text/cmark/cmark-0.29.0.ebuild
new file mode 100644
index 000000000000..00e9f8c59369
--- /dev/null
+++ b/app-text/cmark/cmark-0.29.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit cmake-utils python-any-r1
+
+DESCRIPTION="CommonMark parsing and rendering library and program in C"
+HOMEPAGE="https://github.com/commonmark/cmark"
+SRC_URI="https://github.com/commonmark/cmark/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/0.29.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMARK_LIB_FUZZER=OFF
+ -DCMARK_SHARED=ON
+ -DCMARK_STATIC=OFF
+ -DCMARK_TESTS="$(usex test)"
+ )
+ cmake-utils_src_configure
+}