summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2021-09-27 22:25:50 +0300
committerIonen Wolkens <ionen@gentoo.org>2021-09-28 20:56:35 -0400
commitef42a7f69b0f13c7c03f737a7ba6212201c25ee5 (patch)
treed16068c5f35725dd5406fc8f3142ac842f2c0be0 /app-text/cmark
parentapp-editors/kakoune: Drop old release. (diff)
downloadgentoo-ef42a7f69b0f13c7c03f737a7ba6212201c25ee5.tar.gz
gentoo-ef42a7f69b0f13c7c03f737a7ba6212201c25ee5.tar.bz2
gentoo-ef42a7f69b0f13c7c03f737a7ba6212201c25ee5.zip
app-text/cmark: update to 0.30.2
Updated to EAPI=8. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-text/cmark')
-rw-r--r--app-text/cmark/Manifest1
-rw-r--r--app-text/cmark/cmark-0.30.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-text/cmark/Manifest b/app-text/cmark/Manifest
index c54ea3ac458e..8b66ab3fabd4 100644
--- a/app-text/cmark/Manifest
+++ b/app-text/cmark/Manifest
@@ -1,2 +1,3 @@
DIST cmark-0.29.0.tar.gz 234545 BLAKE2B 1571cdf08f85142ff790db811b7973f2d95a7b1c8669af467cbeac1ad0907826a46f7e0e3ba717ba677746406f8372e40b9878f7810d317fa3c0e14db06dc8fb SHA512 06eb110cfd90c9e980c022b7588e28864d15a4da5d07d61ad4b27c6de47367492b9e58e9434e62b07517aa6dc484f17af13916808be3188f38c37d20cbf33112
DIST cmark-0.30.1.tar.gz 245126 BLAKE2B 4b6b7bcd87f931a50849d70afdd8593131fec6d937a804432444045b90eb6813a56c50e08dbb94bd424e0d5d53f9323f596d1bd2d1ab363bef742fe8d24971a6 SHA512 883bf559874f05af501de9dbce7e08c7297c09ebb26b3e08f55a8a5c43109e47ac14d129a2db31d7f105803e7259e3e104fe4241fd5c1248820a96e5228008f4
+DIST cmark-0.30.2.tar.gz 246033 BLAKE2B 487f5adf47afdd4133e16b6cca1403cd555f8722b47c423960909de73aacac1d0f8b16311f6d5349addb5f03a86562545bb2ec80771b822bb8e5b82816375124 SHA512 aaa9b2103cf89c522f9b42a2b43c07ecf75e07eb42214c0be5de17682ea1faf9c85e3dd28fe91d446b69a34f9980bcab6e276a99b42540c40c9ee1481b3a0d17
diff --git a/app-text/cmark/cmark-0.30.2.ebuild b/app-text/cmark/cmark-0.30.2.ebuild
new file mode 100644
index 000000000000..67faa19c8c54
--- /dev/null
+++ b/app-text/cmark/cmark-0.30.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit cmake python-any-r1
+
+DESCRIPTION="CommonMark parsing and rendering library and program in C"
+HOMEPAGE="https://github.com/commonmark/cmark"
+SRC_URI="https://github.com/commonmark/cmark/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMARK_LIB_FUZZER=OFF
+ -DCMARK_SHARED=ON
+ -DCMARK_STATIC=OFF
+ -DCMARK_TESTS="$(usex test)"
+ )
+ cmake_src_configure
+}