summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2018-05-24 01:08:03 +0700
committerAndrey Grozin <grozin@gentoo.org>2018-05-24 01:09:01 +0700
commit454aa9c1f04b9411a0e43c3fdf2ddb6baf658a2f (patch)
treef9a7eff928fa501ad38c30bb73f99f300754601a /app-text/coolreader/coolreader-3.1.2.71-r3.ebuild
parentsys-cluster/cinder: 12.0.1 stable with cleanup (diff)
downloadgentoo-454aa9c1f04b9411a0e43c3fdf2ddb6baf658a2f.tar.gz
gentoo-454aa9c1f04b9411a0e43c3fdf2ddb6baf658a2f.tar.bz2
gentoo-454aa9c1f04b9411a0e43c3fdf2ddb6baf658a2f.zip
app-text/coolreader: cleaning old
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-text/coolreader/coolreader-3.1.2.71-r3.ebuild')
-rw-r--r--app-text/coolreader/coolreader-3.1.2.71-r3.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/app-text/coolreader/coolreader-3.1.2.71-r3.ebuild b/app-text/coolreader/coolreader-3.1.2.71-r3.ebuild
deleted file mode 100644
index 9c7e43e5f3f1..000000000000
--- a/app-text/coolreader/coolreader-3.1.2.71-r3.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-WX_GTK_VER="3.0"
-
-inherit cmake-utils wxwidgets
-
-if [ "${PV}" == 9999 ]
-then
- inherit git-r3
- # github mirror has some new commits to fix page margins settings
- # sourceforge mirror saved as backup
- #EGIT_REPO_URI="git://git.code.sf.net/p/crengine/crengine"
- EGIT_REPO_URI="https://github.com/buggins/coolreader.git"
- SRC_URI=""
-else
- # git tag cr3.1.2-71
- SRC_URI="https://dev.gentoo.org/~grozin/${P}.tar.bz2"
-fi
-
-DESCRIPTION="CoolReader - reader of eBook files (fb2,epub,htm,rtf,txt)"
-HOMEPAGE="https://sourceforge.net/projects/crengine/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="wxwidgets"
-
-DEPEND="sys-libs/zlib
- media-libs/libpng:0
- virtual/jpeg:0
- media-libs/freetype
- wxwidgets? ( x11-libs/wxGTK:${WX_GTK_VER} )
- !wxwidgets? ( dev-qt/qtcore:5 dev-qt/qtgui:5 dev-qt/qtwidgets:5 )"
-RDEPEND="${DEPEND}
- wxwidgets? ( || ( media-fonts/liberation-fonts media-fonts/corefonts ) )"
-
-# 1st patch: To save cr3.ini to ~homedir.
-# 2nd patch: To build QT5 and WX GUI version of coolreader3;
-# setting correct vesrion number and years of cr3qt/cr3wx;
-# internal switching between wxGTK 2.8 or 3.0 version;
-# show wxWidgets version in "About" dialog window;
-# disabling "iCCP: known incorrect sRGB profile" warning popup window for wxwidgets GUI
-
-PATCHES=( "${FILESDIR}/cr3ini.diff" "${FILESDIR}/cr3.1.2.71-r1_qt5_wx.diff" )
-
-src_configure() {
- CMAKE_USE_DIR="${S}"
- CMAKE_BUILD_TYPE="Release"
- if use wxwidgets; then
- setup-wxwidgets
- local mycmakeargs=(-D GUI=WX)
- else
- local mycmakeargs=(-D GUI=QT5)
- fi
- cmake-utils_src_configure
-}