summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-04-20 16:43:32 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-04-20 16:43:32 +0700
commit1ba713a2cefc398c1b382f8686aa62588f05bb22 (patch)
tree7a7d41d602fce5b7693a1acf2da17660aff93dec /app-text/crwx-ng
parentapp-text/crqt-ng: remove old revision (diff)
downloadgentoo-1ba713a2cefc398c1b382f8686aa62588f05bb22.tar.gz
gentoo-1ba713a2cefc398c1b382f8686aa62588f05bb22.tar.bz2
gentoo-1ba713a2cefc398c1b382f8686aa62588f05bb22.zip
app-text/crwx-ng: DEPEND on crengine-ng:0/<subslot>
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'app-text/crwx-ng')
-rw-r--r--app-text/crwx-ng/crwx-ng-0.2.0-r3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-text/crwx-ng/crwx-ng-0.2.0-r3.ebuild b/app-text/crwx-ng/crwx-ng-0.2.0-r3.ebuild
new file mode 100644
index 000000000000..64cec1b653a4
--- /dev/null
+++ b/app-text/crwx-ng/crwx-ng-0.2.0-r3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+WX_GTK_VER="3.0-gtk3"
+inherit cmake wxwidgets
+
+DESCRIPTION="Cross-platform e-book reader"
+HOMEPAGE="https://gitlab.com/coolreader-ng/crwx-ng"
+SRC_URI="https://gitlab.com/coolreader-ng/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gif +svg +chm +harfbuzz +libunibreak +fribidi +zstd +libutf8proc"
+
+CDEPEND=">=app-text/crengine-ng-0.9.7:0=[png,jpeg,fontconfig,gif=,svg=,chm=,harfbuzz=,fribidi=,zstd=,libutf8proc=]
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+BDEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}
+ virtual/ttf-fonts"
+
+PATCHES=( "${FILESDIR}"/${P}.patch )