summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2024-02-14 21:44:00 +0700
committerAndrey Grozin <grozin@gentoo.org>2024-02-14 21:44:00 +0700
commit2c168251ab1b9f55042578cb9ead5c25ed89039f (patch)
treee29064b50b6ecb341da686dcda86a3c504cd1da6 /app-text/crwx-ng
parentsci-mathematics/wxmaxima: remove old version (diff)
downloadgentoo-2c168251ab1b9f55042578cb9ead5c25ed89039f.tar.gz
gentoo-2c168251ab1b9f55042578cb9ead5c25ed89039f.tar.bz2
gentoo-2c168251ab1b9f55042578cb9ead5c25ed89039f.zip
app-text/crwx-ng: add missing setup-wxwidgets
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'app-text/crwx-ng')
-rw-r--r--app-text/crwx-ng/crwx-ng-0.3.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-text/crwx-ng/crwx-ng-0.3.1-r1.ebuild b/app-text/crwx-ng/crwx-ng-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..8d503c432457
--- /dev/null
+++ b/app-text/crwx-ng/crwx-ng-0.3.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+WX_GTK_VER="3.2-gtk3"
+inherit cmake wxwidgets xdg
+
+DESCRIPTION="Cross-platform e-book reader"
+HOMEPAGE="https://gitlab.com/coolreader-ng/crwx-ng"
+SRC_URI="https://gitlab.com/coolreader-ng/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gif +svg +chm +harfbuzz +libunibreak +fribidi +zstd +libutf8proc"
+
+CDEPEND=">=app-text/crengine-ng-0.9.7:0=[png,jpeg,fontconfig,gif=,svg=,chm=,harfbuzz=,fribidi=,zstd=,libutf8proc=]
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
+BDEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}
+ virtual/ttf-fonts"
+
+pkg_prepare() {
+ setup-wxwidgets
+}