summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-18 00:44:49 +0100
committerSam James <sam@gentoo.org>2022-06-18 00:44:55 +0100
commit5a106e305ef06e4db20ba8510aced7d668d19f5b (patch)
tree436e42783d4db94b4f109bb1d492feb36eafce3b /app-text/dictd
parentapp-text/dictd: Fix the build with rlibtool (diff)
downloadgentoo-5a106e305ef06e4db20ba8510aced7d668d19f5b.tar.gz
gentoo-5a106e305ef06e4db20ba8510aced7d668d19f5b.tar.bz2
gentoo-5a106e305ef06e4db20ba8510aced7d668d19f5b.zip
app-text/dictd: force -j1
Closes: https://bugs.gentoo.org/743292 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/dictd')
-rw-r--r--app-text/dictd/dictd-1.13.0-r4.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/app-text/dictd/dictd-1.13.0-r4.ebuild b/app-text/dictd/dictd-1.13.0-r4.ebuild
index a8aafc51843e..19723217a411 100644
--- a/app-text/dictd/dictd-1.13.0-r4.ebuild
+++ b/app-text/dictd/dictd-1.13.0-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -63,27 +63,31 @@ src_configure() {
}
src_compile() {
+ # -j1 for bug #743292
+
if use minimal; then
- emake dictfmt dictzip dictzip
+ emake -j1 dictfmt dictzip dictzip
else
- emake
+ emake -j1
fi
}
src_test() {
use minimal && return 0 # All tests are for dictd which we don't build...
+
if [[ ${EUID} -eq 0 ]]; then
# If dictd is run as root user (-userpriv) it drops its privileges to
# dictd user and group. Give dictd group write access to test directory.
chown :dictd "${WORKDIR}" "${S}/test" || die
chmod 770 "${WORKDIR}" "${S}/test" || die
fi
- emake test
+
+ emake -j1 test
}
src_install() {
if use minimal; then
- emake DESTDIR="${ED}" install.dictzip install.dict install.dictfmt
+ emake -j1 DESTDIR="${ED}" install.dictzip install.dict install.dictfmt
else
default