summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-10-22 19:09:57 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2017-10-22 19:11:40 +0100
commit8689fa2a0ccf320229054f49e1fdf8646704dd7c (patch)
tree9870ea0a236880882cced27502b06d1c1875738b /app-text/discount/discount-2.2.2.ebuild
parentmedia-sound/mpg123: stable 1.25.6 for hppa, bug #631604 (diff)
downloadgentoo-8689fa2a0ccf320229054f49e1fdf8646704dd7c.tar.gz
gentoo-8689fa2a0ccf320229054f49e1fdf8646704dd7c.tar.bz2
gentoo-8689fa2a0ccf320229054f49e1fdf8646704dd7c.zip
app-text/discount: respect gentoo's CC propagation
Before the change build log looks like: cc -I. ... -g -O2 -pipe -fdiagnostics-show-option -frecord-gcc-switches -fPIC -I. -c main.c After the change: x86_64-pc-linux-gnu-gcc -I. ... -g -O2 -pipe -fdiagnostics-show-option -frecord-gcc-switches -fPIC -I. -c main.c See https://devmanual.gentoo.org/ebuild-writing/functions/src_compile/building/ for more details. Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'app-text/discount/discount-2.2.2.ebuild')
-rw-r--r--app-text/discount/discount-2.2.2.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/app-text/discount/discount-2.2.2.ebuild b/app-text/discount/discount-2.2.2.ebuild
index a16f7b4e4025..bb4f809a591c 100644
--- a/app-text/discount/discount-2.2.2.ebuild
+++ b/app-text/discount/discount-2.2.2.ebuild
@@ -3,6 +3,8 @@
EAPI=6
+inherit toolchain-funcs
+
DESCRIPTION="A Markdown-to HTML translator written in C"
HOMEPAGE="http://www.pell.portland.or.us/~orc/Code/discount/"
SRC_URI="http://www.pell.portland.or.us/~orc/Code/${PN}/${P}.tar.bz2"
@@ -46,6 +48,7 @@ src_configure() {
--debian-glitch
)
einfo "Running ${configure_call[@]}"
+ CC="$(tc-getCC)" \
"${configure_call[@]}" || die
}