summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2020-02-07 09:42:50 -0600
committerBen Kohler <bkohler@gentoo.org>2020-02-07 09:42:50 -0600
commita2bc21a5157b6be3e6aec7bb628cfcf7f8f9ef6b (patch)
tree136cabb28a9ea03b157d666bef02f9af4321d5df /app-text/discount
parentnet-analyzer/telegraf: 1.13.3 bump (diff)
downloadgentoo-a2bc21a5157b6be3e6aec7bb628cfcf7f8f9ef6b.tar.gz
gentoo-a2bc21a5157b6be3e6aec7bb628cfcf7f8f9ef6b.tar.bz2
gentoo-a2bc21a5157b6be3e6aec7bb628cfcf7f8f9ef6b.zip
app-text/discount: fix build of libmarkdown
Also remove custom doins for pkgconfig file, now handled by build system Closes: https://bugs.gentoo.org/708312 Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'app-text/discount')
-rw-r--r--app-text/discount/discount-2.2.6.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/app-text/discount/discount-2.2.6.ebuild b/app-text/discount/discount-2.2.6.ebuild
index 9d8ffa589581..5188f84a09a9 100644
--- a/app-text/discount/discount-2.2.6.ebuild
+++ b/app-text/discount/discount-2.2.6.ebuild
@@ -47,14 +47,16 @@ src_configure() {
"${configure_call[@]}" || die
}
+src_compile() {
+ emake libmarkdown
+ emake
+}
+
src_install() {
emake \
DESTDIR="${D}" \
$(usex minimal install install.everything) \
SAMPLE_PFX="${PN}-"
-
- insinto /usr/$(get_libdir)/pkgconfig
- doins libmarkdown.pc
}
pkg_postinst() {