summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2023-03-30 11:59:14 -0500
committerBen Kohler <bkohler@gentoo.org>2023-03-30 13:05:14 -0500
commite120af8c62026286010ddac9916ce6d67c1c0102 (patch)
tree95982febb46ddf88d84a1c21a7aa58287f8a7bbd /app-text/discount
parentapp-backup/backupninja: drop 1.2.1-r1 (diff)
downloadgentoo-e120af8c62026286010ddac9916ce6d67c1c0102.tar.gz
gentoo-e120af8c62026286010ddac9916ce6d67c1c0102.tar.bz2
gentoo-e120af8c62026286010ddac9916ce6d67c1c0102.zip
app-text/discount: drop 2.2.7b
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'app-text/discount')
-rw-r--r--app-text/discount/Manifest1
-rw-r--r--app-text/discount/discount-2.2.7b.ebuild67
2 files changed, 0 insertions, 68 deletions
diff --git a/app-text/discount/Manifest b/app-text/discount/Manifest
index 943f936ff693..0c3dbf6d88e4 100644
--- a/app-text/discount/Manifest
+++ b/app-text/discount/Manifest
@@ -1,3 +1,2 @@
-DIST discount-2.2.7b.tar.bz2 102685 BLAKE2B 1af4d47248e4a65ea1517b03d0b1a0b15eb79bdb7d1f00779515e2a1113b2a923f5d9e5d0a93d63cfc6c7257f11d3825d9baa55c7f2252fe3d2513785ab67ae3 SHA512 d68ffb85ae3e6d6ce8a2e506609bd4cb042617e350d113dd632a1ed81adb0b076df75ca4e70e97d43f3a3a2907555a9f28087a3762f41806289c526af3c55806
DIST discount-2.2.7c.tar.gz 133282 BLAKE2B 3258cfa34d58ef5944ae5282f6df061b8183bccc1ca7f9f3a39b3c001a8b86a4deb86b80d109d937e334b2773e5065a0f6c212ac7a79317ce2ae665778a023e2 SHA512 2a959fb24d7291b3a8c6d659b5c904b8c2f8b6d9b0666e998ca5313533cc25898b9c2114f7922272f3bc6b9bfe4bc486fe08c620b4cb2a2282624e128dc92781
DIST discount-3.0.0a.tar.gz 140250 BLAKE2B 1e89f9c58c4d90157a9ccd925b89f098538c93191937e86eeefd32810e937feb78b6eeab96aead029fc35e4bf6699a40f67bdceb3c2d70fdc645fcd14091a3e7 SHA512 d86bfc6d3e11131622046418a1f54bd9dfa5f1233e510189cd2c89dc857da31e88ffbe6670cc506ca8b9763e8fb74ed215f1018f83e25767c77acb8a7c296b8a
diff --git a/app-text/discount/discount-2.2.7b.ebuild b/app-text/discount/discount-2.2.7b.ebuild
deleted file mode 100644
index cbfe59ee5c39..000000000000
--- a/app-text/discount/discount-2.2.7b.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-DESCRIPTION="A Markdown-to HTML translator written in C"
-HOMEPAGE="http://www.pell.portland.or.us/~orc/Code/discount/"
-SRC_URI="http://www.pell.portland.or.us/~orc/Code/${PN}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0/2.2.7"
-KEYWORDS="~alpha amd64 ~arm arm64 ~ia64 ppc ppc64 ~riscv sparc x86"
-IUSE="minimal test"
-RESTRICT="!test? ( test )"
-
-src_prepare() {
- default
-
- # for QA, we remove the Makefile’s usage of install -s.
- # Drop ldconfig invocation.
- # Force “librarian.sh” to respect LDFLAGS ($FLAGS should have CFLAGS
- # at that point).
- sed -i \
- -e '/INSTALL_PROGRAM/s,\$_strip ,,' \
- -e 's/\(LDCONFIG=\).*/\1:/' \
- -e 's/\(.\)\$FLAGS/& \1$LDFLAGS/' \
- configure.inc || die "sed configure.inc failed"
-}
-
-src_configure() {
- local configure_call=(
- ./configure.sh
- --libdir="${EPREFIX}/usr/$(get_libdir)"
- --prefix="${EPREFIX}/usr"
- --mandir="${EPREFIX}/usr/share/man"
- --shared
- --pkg-config
- $(usex minimal '' --enable-all-features)
- # Enable deterministic HTML generation behavior. Otherwise, will
- # actually call rand() as part of its serialization code...
- --debian-glitch
- )
- einfo "Running ${configure_call[@]}"
- CC="$(tc-getCC)" AR="$(tc-getAR)" \
- "${configure_call[@]}" || die
-}
-
-src_compile() {
- emake libmarkdown
- emake
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- $(usex minimal install install.everything) \
- SAMPLE_PFX="${PN}-"
-}
-
-pkg_postinst() {
- if ! use minimal; then
- elog 'Sample binaries with overly-generic names have been'
- elog "prefixed with \"${PN}-\"."
- fi
-}