summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/djview/djview-4.10.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/djview/djview-4.10.ebuild')
-rw-r--r--app-text/djview/djview-4.10.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/app-text/djview/djview-4.10.ebuild b/app-text/djview/djview-4.10.ebuild
new file mode 100644
index 000000000000..821a1e1f9bde
--- /dev/null
+++ b/app-text/djview/djview-4.10.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools gnome2-utils fdo-mime flag-o-matic versionator toolchain-funcs multilib nsplugins
+
+MY_P=${PN}-$(replace_version_separator 2 '-')
+
+DESCRIPTION="Portable DjVu viewer using Qt4"
+HOMEPAGE="http://djvu.sourceforge.net/djview4.html"
+SRC_URI="mirror://sourceforge/djvu/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug nsplugin"
+
+RDEPEND="
+ >=app-text/djvu-3.5.22-r1
+ dev-qt/qtdbus:4
+ dev-qt/qtopengl:4
+ dev-qt/qtgui:4"
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.67
+ virtual/pkgconfig
+ nsplugin? ( dev-libs/glib:2 )"
+
+src_prepare() {
+ # Force XEmbed instead of Xt-based mainloop (disable Xt autodep)
+ sed -e 's:\(ac_xt=\)yes:\1no:' -i configure* || die
+ sed 's/AC_CXX_OPTIMIZE/OPTS=;AC_SUBST(OPTS)/' -i configure.ac || die #263688
+ rm aclocal.m4 config/{libtool.m4,install-sh,ltmain.sh,lt*.m4}
+ AT_M4DIR="config" eautoreconf
+}
+
+src_configure() {
+ # See config/acinclude.m4
+ use debug || append-cppflags "-DNDEBUG"
+
+ # QTDIR is needed because of kde3
+ QTDIR=/usr \
+ econf \
+ --with-x \
+ $(use_enable nsplugin nsdejavu) \
+ --disable-desktopfiles
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ plugindir=/usr/$(get_libdir)/${PLUGINS_DIR} \
+ install
+
+ dodoc README NEWS
+
+ cd desktopfiles
+ insinto /usr/share/icons/hicolor/32x32/apps
+ newins prebuilt-hi32-djview4.png djvulibre-djview4.png
+ insinto /usr/share/icons/hicolor/64x64/apps
+ newins prebuilt-hi64-djview4.png djvulibre-djview4.png
+ insinto /usr/share/icons/hicolor/scalable/apps
+ newins djview.svg djvulibre-djview4.svg
+ sed -i -e 's/Exec=djview4/Exec=djview/' djvulibre-djview4.desktop
+ domenu djvulibre-djview4.desktop
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}