summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-05 18:49:39 -0500
committerSam James <sam@gentoo.org>2024-03-06 03:36:19 +0000
commite6e08c21c9ac1f32715c11caba482883d824b9c8 (patch)
treeb48925c25388aa90119e49963256542a309f5f4f /app-text/enchant/enchant-2.6.1.ebuild
parentdev-util/plan9port: mark as LTO-unsafe (diff)
downloadgentoo-e6e08c21c9ac1f32715c11caba482883d824b9c8.tar.gz
gentoo-e6e08c21c9ac1f32715c11caba482883d824b9c8.tar.bz2
gentoo-e6e08c21c9ac1f32715c11caba482883d824b9c8.zip
app-text/enchant: make sure elibtoolize is applied
Needed to e.g. pass LTO warning flags through to the linker. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/enchant/enchant-2.6.1.ebuild')
-rw-r--r--app-text/enchant/enchant-2.6.1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/app-text/enchant/enchant-2.6.1.ebuild b/app-text/enchant/enchant-2.6.1.ebuild
index 784efb038eaf..d75574d1ad61 100644
--- a/app-text/enchant/enchant-2.6.1.ebuild
+++ b/app-text/enchant/enchant-2.6.1.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit libtool
+
DESCRIPTION="Spellchecker wrapping library"
HOMEPAGE="https://abiword.github.io/enchant/"
SRC_URI="https://github.com/AbiWord/enchant/releases/download/v${PV}/${P}.tar.gz"
@@ -39,6 +41,11 @@ QA_CONFIG_IMPL_DECL_SKIP=(
unreachable
)
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
local myconf=(
--disable-static