summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/expander
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/expander')
-rw-r--r--app-text/expander/Manifest1
-rw-r--r--app-text/expander/expander-2.0.5-r1.ebuild52
-rw-r--r--app-text/expander/files/expander-2.0.5-gentoo.patch58
-rw-r--r--app-text/expander/metadata.xml8
4 files changed, 119 insertions, 0 deletions
diff --git a/app-text/expander/Manifest b/app-text/expander/Manifest
new file mode 100644
index 000000000000..7ec8c52b971e
--- /dev/null
+++ b/app-text/expander/Manifest
@@ -0,0 +1 @@
+DIST nedit_expander_kit_2.05.tar.gz 92571 SHA256 6d2ebebfc50b277b375eba6325d8d9ef381a9a12d8e581c0b65ce28e1f0eff15 SHA512 a9d5e97db95eec9f98d71360c6af5a6908f31f59221ac1f509ae4f661b0614610b9591b9e2f58bba1175a6b609407d720369ba99cecb5496133d889bf93788ee WHIRLPOOL 8eb5664b1892234db2463c63e32f9743375da979ccdd7af1f5fbdd8b25713ab2c65c2e07e1e0d43e8c06cfea98847c78f5ed7da86e1727a6669615b7c82b606a
diff --git a/app-text/expander/expander-2.0.5-r1.ebuild b/app-text/expander/expander-2.0.5-r1.ebuild
new file mode 100644
index 000000000000..d5995a569e2e
--- /dev/null
+++ b/app-text/expander/expander-2.0.5-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Expander is a utility that acts as a filter for text editors"
+HOMEPAGE="http://www.nedit.org"
+SRC_URI="ftp://ftp.nedit.org/pub/contrib/misc/nedit_expander_kit_2.05.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-linux ~ppc-macos"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake -C src CC=$(tc-getCC)
+}
+
+src_install() {
+ cd src
+ dobin expander boxcomment align_columns align_comments where_is
+ dosym /usr/bin/boxcomment /usr/bin/unboxcomment
+
+ insinto /usr/share/${P}
+ doins "${S}"/service
+ for x in defs macros misc templates ; do
+ insinto /usr/share/${P}/${x}
+ doins "${S}"/${x}/*
+ done
+
+ cd "${S}"/docs
+ doman *.1
+
+ cd "${S}"
+ dodoc ChangeLog INSTALL README USAGE
+}
+
+pkg_postinst() {
+ elog
+ elog "Instructions for using expander with NEdit are in /usr/share/doc/${PF}/INSTALL"
+ elog "Macro, definition and template files can be found in /usr/share/${P}"
+ elog
+}
diff --git a/app-text/expander/files/expander-2.0.5-gentoo.patch b/app-text/expander/files/expander-2.0.5-gentoo.patch
new file mode 100644
index 000000000000..460a8164cee5
--- /dev/null
+++ b/app-text/expander/files/expander-2.0.5-gentoo.patch
@@ -0,0 +1,58 @@
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -3,15 +3,14 @@
+ bindir = $(BINDIR)/
+
+ copy = ln -fs
+-CFLAGS += -v -g # -DNEED_GETOPT_PROTO_TYPE
+-compiler = cc $(CFLAGS)
++compiler = $(CC) $(CFLAGS)
+
+ executables = expander boxcomment align_columns align_comments where_is
+
+ #--------------
+ # Build Targets
+ #--------------
+-all: verify $(executables)
++all: $(executables)
+
+ verify:
+ @if [ "$(bindir)" = "/" ]; then \
+@@ -24,32 +23,31 @@
+ # Abbreviation expansion filter program (with NEdit, language sensitive)
+ #-----------------------------------------------------------------------
+ expander: expander.c
+- $(compiler) -o $(bindir)$@ $?
++ $(compiler) $(LDFLAGS) -o $@ $?
+
+ #--------------------------------------------------------------------------
+ # Surround given text with open ended box. (with NEdit, language sensitive)
+ #--------------------------------------------------------------------------
+ boxcomment: boxcomment.c
+- $(compiler) -o $(bindir)$@ $?
+- @if [ ! -f $(bindir)un$@ ]; then $(copy) $(bindir)$@ $(bindir)un$@; fi
++ $(compiler) $(LDFLAGS) -o $@ $?
+
+ #-------------------------------------------------------------------------------
+ # Align ragged looking 'C' style comments (good substitute for align_equals too)
+ #-------------------------------------------------------------------------------
+ align_comments: align_comments.c
+- $(compiler) -o $(bindir)$@ $?
++ $(compiler) $(LDFLAGS) -o $@ $?
+
+ #----------------------------
+ # Align given text in columns
+ #----------------------------
+ align_columns: align_columns.c
+- $(compiler) -o $(bindir)$@ $?
++ $(compiler) $(LDFLAGS) -o $@ $?
+
+ #----------------------------------------------
+ # File locator (substitute for which, where...)
+ #----------------------------------------------
+ where_is: where_is.c
+- $(compiler) -o $(bindir)$@ $?
++ $(compiler) $(LDFLAGS) -o $@ $?
+
+ #------------------------------------------------
+ # Here is how to uninstall the executables built.
diff --git a/app-text/expander/metadata.xml b/app-text/expander/metadata.xml
new file mode 100644
index 000000000000..59e2b8f78cb5
--- /dev/null
+++ b/app-text/expander/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <name>Default assignee for orphaned packages</name>
+ </maintainer>
+</pkgmetadata>