summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-09-19 01:25:41 -0400
committerTim Harder <radhermit@gentoo.org>2017-09-19 02:24:02 -0400
commit70c0da4c651c629eba8f740f5cae47f3e3d630f9 (patch)
treef5aaca6b659edbeac2a91355013c663bba8207be /app-text/extract_url/extract_url-1.6.2.ebuild
parentdev-ruby/ox: add 2.7.0 (diff)
downloadgentoo-70c0da4c651c629eba8f740f5cae47f3e3d630f9.tar.gz
gentoo-70c0da4c651c629eba8f740f5cae47f3e3d630f9.tar.bz2
gentoo-70c0da4c651c629eba8f740f5cae47f3e3d630f9.zip
app-text/extract_url: initial import
Diffstat (limited to 'app-text/extract_url/extract_url-1.6.2.ebuild')
-rw-r--r--app-text/extract_url/extract_url-1.6.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-text/extract_url/extract_url-1.6.2.ebuild b/app-text/extract_url/extract_url-1.6.2.ebuild
new file mode 100644
index 000000000000..8ccadeb5e0f5
--- /dev/null
+++ b/app-text/extract_url/extract_url-1.6.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="extracts URLs from correctly-encoded MIME email messages or plain text"
+HOMEPAGE="https://www.memoryhole.net/~kyle/extract_url/ https://github.com/m3m0ryh0l3/extracturl/"
+SRC_URI="https://github.com/m3m0ryh0l3/${PN/_/}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-perl/MIME-tools
+ dev-perl/HTML-Parser
+ dev-perl/URI-Find
+ dev-perl/Curses-UI
+ dev-perl/TermReadKey
+"
+
+S=${WORKDIR}/${P/_/}
+
+src_install() {
+ default
+ dodoc extract_urlview.sample
+}