summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-01-23 21:57:33 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-01-23 21:57:42 +0000
commit46beef910284631a394a4060487d8bd0ae6dd61a (patch)
treee3b3158857bd9da2e3cad7ff3243a2e489d30398 /app-text/fbpdf/fbpdf-0_p20161202.ebuild
parentsys-devel/llvm: Force x86 CHOST to i386-* for compiler-rt compat (diff)
downloadgentoo-46beef910284631a394a4060487d8bd0ae6dd61a.tar.gz
gentoo-46beef910284631a394a4060487d8bd0ae6dd61a.tar.bz2
gentoo-46beef910284631a394a4060487d8bd0ae6dd61a.zip
app-text/fbpdf: bump to support mupdf-1.10, bug #606876
Reported-by: Toralf Förster Bug: https://bugs.gentoo.org/606876 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-text/fbpdf/fbpdf-0_p20161202.ebuild')
-rw-r--r--app-text/fbpdf/fbpdf-0_p20161202.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-text/fbpdf/fbpdf-0_p20161202.ebuild b/app-text/fbpdf/fbpdf-0_p20161202.ebuild
new file mode 100644
index 000000000000..0dd4cc602611
--- /dev/null
+++ b/app-text/fbpdf/fbpdf-0_p20161202.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="framebuffer pdf and djvu viewer"
+HOMEPAGE="http://repo.or.cz/fbpdf.git"
+SRC_URI="https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=app-text/mupdf-1.10:0=
+ dev-lang/mujs:0=
+ media-libs/freetype:2=
+ media-libs/jbig2dec:0=
+ virtual/jpeg:0=
+ media-libs/openjpeg:0=
+ dev-libs/openssl:0=
+ app-text/djvu:0=
+"
+
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+PATCHES=("${FILESDIR}"/${P}-format.patch)
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin fbpdf fbdjvu
+ dodoc README
+}