summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-05-02 09:08:54 -0300
committerMatt Turner <mattst88@gentoo.org>2023-05-02 10:54:38 -0400
commit069f35ecde4d4563a6d3802097c4b7e1a730ec7d (patch)
treef7c04e7b40ef6fc3e22681f3ebd8421a5156f476 /app-text/gspell/gspell-1.12.1.ebuild
parentdev-util/gitlab-runner: drop 15.8.3 (diff)
downloadgentoo-069f35ecde4d4563a6d3802097c4b7e1a730ec7d.tar.gz
gentoo-069f35ecde4d4563a6d3802097c4b7e1a730ec7d.tar.bz2
gentoo-069f35ecde4d4563a6d3802097c4b7e1a730ec7d.zip
app-text/gspell: Version bump to 1.12.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/30835 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-text/gspell/gspell-1.12.1.ebuild')
-rw-r--r--app-text/gspell/gspell-1.12.1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/app-text/gspell/gspell-1.12.1.ebuild b/app-text/gspell/gspell-1.12.1.ebuild
new file mode 100644
index 000000000000..16d18c659738
--- /dev/null
+++ b/app-text/gspell/gspell-1.12.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="Spell check library for GTK+ applications"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gspell"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/2" # subslot = libgspell-1 soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+introspection +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=app-text/enchant-2.2:2
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.20:3[introspection?]
+ dev-libs/icu:=
+ introspection? ( >=dev-libs/gobject-introspection-1.42.0:= )
+"
+DEPEND="${RDEPEND}
+ test? ( sys-apps/dbus )
+"
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.25
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+ test? (
+ app-text/enchant:2[hunspell]
+ || (
+ app-dicts/myspell-en[l10n_en(+)]
+ app-dicts/myspell-en[l10n_en-US(+)]
+ )
+ )
+"
+# Tests require a en_US dictionary and fail with deprecated enchant aspell backend:
+# So enchant[hunspell] + myspell-en ensure they pass (hunspell is ordered before aspell),
+# however a different backend like hspell or nuspell + their en_US dict might be fine too,
+# but we don't support them at this time (2020-04-12) in enchant:2
+
+src_prepare() {
+ use vala && vala_setup
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ virtx dbus-run-session emake check
+}