summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-12-13 23:03:34 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2015-12-13 23:10:22 +0100
commit525eeb606d9028dafede361f696ea599fb6ccdc6 (patch)
tree58bd8ce8edf90ed463e44b0d856015e1111b51c3 /app-text/gspell
parentnet-misc/rygel: version bump to 0.28.2 (diff)
downloadgentoo-525eeb606d9028dafede361f696ea599fb6ccdc6.tar.gz
gentoo-525eeb606d9028dafede361f696ea599fb6ccdc6.tar.bz2
gentoo-525eeb606d9028dafede361f696ea599fb6ccdc6.zip
app-text/gspell: version bump to 0.2.2, fix introspection and vala USE flags dependencies
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-text/gspell')
-rw-r--r--app-text/gspell/Manifest1
-rw-r--r--app-text/gspell/gspell-0.1.2.ebuild7
-rw-r--r--app-text/gspell/gspell-0.2.2.ebuild44
3 files changed, 49 insertions, 3 deletions
diff --git a/app-text/gspell/Manifest b/app-text/gspell/Manifest
index f8154df6b559..968a0b87cec0 100644
--- a/app-text/gspell/Manifest
+++ b/app-text/gspell/Manifest
@@ -1 +1,2 @@
DIST gspell-0.1.2.tar.xz 355128 SHA256 e8625c57296b6c178bc37659f023342f8edefaaa2c5eccf40de8bd479dbfa8f0 SHA512 8d9bd61f378929217b9461debb58df5070952539f30f6ee211cf13f856dfe5d5216468679a8d7d7b08df47ee6b7b45f25b2b6400212a83de9563e2bf175905bb WHIRLPOOL 44334ac608e9a66c5a6bf011ad21d7d368e29d7923079e947ed5484ae0c7847df1f29dc255979d0da844e1ecba16fa19dfae5b84aefd85287bc63de1465d3ffa
+DIST gspell-0.2.2.tar.xz 358600 SHA256 cecded0f0a8dfe4b28cbb47a6024f82f50b7ffb7476e36032d5f8d741e3f627e SHA512 6f3fe9eecb6d464db549747294e5d39aec1175c104a8210fecee596f255db7b76121fbe4681f27723281078dc7f0cb87effa1e12b9f6be37f04e9004ee9b2b24 WHIRLPOOL ed8df8cf984b5398fcf8b026289de23c793d0426feb76380a7550898557d76af8d5d4abecd3e70d422b4f516549dd0383ab27fb56822c13080341a78dc85ee06
diff --git a/app-text/gspell/gspell-0.1.2.ebuild b/app-text/gspell/gspell-0.1.2.ebuild
index d4bb07bcc899..b2ccffcc875f 100644
--- a/app-text/gspell/gspell-0.1.2.ebuild
+++ b/app-text/gspell/gspell-0.1.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -15,14 +15,15 @@ LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+introspection vala"
+REQUIRED_IUSE="vala? ( introspection )"
RDEPEND="
>=app-text/enchant-1.6.0
>=app-text/iso-codes-0.35
>=dev-libs/glib-2.44:2
>=dev-libs/libxml2-2.5.0:2
- >=x11-libs/gtk+-3.16:3
- >=x11-libs/gtksourceview-3.16:3.0
+ >=x11-libs/gtk+-3.16:3[introspection?]
+ >=x11-libs/gtksourceview-3.16:3.0[introspection?]
introspection? ( >=dev-libs/gobject-introspection-1.42.0:= )
vala? ( $(vala_depend) )
"
diff --git a/app-text/gspell/gspell-0.2.2.ebuild b/app-text/gspell/gspell-0.2.2.ebuild
new file mode 100644
index 000000000000..ed0e226d5314
--- /dev/null
+++ b/app-text/gspell/gspell-0.2.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="Spell check library for GTK+ applications"
+HOMEPAGE="https://wiki.gnome.org/Projects/gspell"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection vala"
+REQUIRED_IUSE="vala? ( introspection )"
+
+RDEPEND="
+ >=app-text/enchant-1.6.0
+ >=app-text/iso-codes-0.35
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.16:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.42.0:= )
+ vala? ( $(vala_depend) )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.24
+ >=dev-util/intltool-0.35.0
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}