summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2019-01-28 20:59:48 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2019-01-28 21:01:33 +0100
commitd6abdc74d3b9741c252a3669fc2444d8a70dfa22 (patch)
treeaf5e715c08e424d864d11124d29ef67dacdf711d /app-text/gtkspell/gtkspell-3.0.10.ebuild
parentsys-apps/s390-tools: mark s390 stable (diff)
downloadgentoo-d6abdc74d3b9741c252a3669fc2444d8a70dfa22.tar.gz
gentoo-d6abdc74d3b9741c252a3669fc2444d8a70dfa22.tar.bz2
gentoo-d6abdc74d3b9741c252a3669fc2444d8a70dfa22.zip
app-text/gtkspell: bump to 3.0.10
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'app-text/gtkspell/gtkspell-3.0.10.ebuild')
-rw-r--r--app-text/gtkspell/gtkspell-3.0.10.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-text/gtkspell/gtkspell-3.0.10.ebuild b/app-text/gtkspell/gtkspell-3.0.10.ebuild
new file mode 100644
index 000000000000..a87cfe4fc106
--- /dev/null
+++ b/app-text/gtkspell/gtkspell-3.0.10.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2 vala
+
+DESCRIPTION="Spell checking widget for GTK"
+HOMEPAGE="http://gtkspell.sourceforge.net/"
+MY_P="${PN}3-${PV}"
+SRC_URI="mirror://sourceforge/project/${PN}/${PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="3/0"
+KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=app-text/enchant-2.0.0
+ app-text/iso-codes
+ dev-libs/glib:2
+ x11-libs/gtk+:3[introspection?]
+ >=x11-libs/pango-1.8.0[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.17
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}