summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2017-09-03 16:05:08 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2017-09-03 18:15:31 +0200
commita4c44773909e4c6807f8e8ac3c21550e1c031eaf (patch)
tree6905ab84b86a4cf999fd2cd79f43db554da3cf2d /app-text/gtkspell/gtkspell-3.0.9.ebuild
parentkde-frameworks/syntax-highlighting: Drop 5.37.0 (r0) (diff)
downloadgentoo-a4c44773909e4c6807f8e8ac3c21550e1c031eaf.tar.gz
gentoo-a4c44773909e4c6807f8e8ac3c21550e1c031eaf.tar.bz2
gentoo-a4c44773909e4c6807f8e8ac3c21550e1c031eaf.zip
app-text/gtkspell: version bump 3.0.7 → 3.0.9, bug #629760
Closes: https://bugs.gentoo.org/show_bug.cgi?id=629760 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-text/gtkspell/gtkspell-3.0.9.ebuild')
-rw-r--r--app-text/gtkspell/gtkspell-3.0.9.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-text/gtkspell/gtkspell-3.0.9.ebuild b/app-text/gtkspell/gtkspell-3.0.9.ebuild
new file mode 100644
index 000000000000..a5ee97156fc5
--- /dev/null
+++ b/app-text/gtkspell/gtkspell-3.0.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2 vala
+
+DESCRIPTION="Spell checking widget for GTK"
+HOMEPAGE="http://gtkspell.sourceforge.net/"
+MY_P="${PN}3-${PV}"
+SRC_URI="mirror://sourceforge/project/${PN}/${PV}/${MY_P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="3/0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=app-text/enchant-1.1.6
+ app-text/iso-codes
+ dev-libs/glib:2
+ x11-libs/gtk+:3[introspection?]
+ >=x11-libs/pango-1.8.0[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.17
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}