summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/gtkspell
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/gtkspell')
-rw-r--r--app-text/gtkspell/Manifest2
-rw-r--r--app-text/gtkspell/gtkspell-2.0.16.ebuild40
-rw-r--r--app-text/gtkspell/gtkspell-3.0.4.ebuild48
-rw-r--r--app-text/gtkspell/metadata.xml11
4 files changed, 101 insertions, 0 deletions
diff --git a/app-text/gtkspell/Manifest b/app-text/gtkspell/Manifest
new file mode 100644
index 000000000000..780768af9783
--- /dev/null
+++ b/app-text/gtkspell/Manifest
@@ -0,0 +1,2 @@
+DIST gtkspell-2.0.16.tar.gz 351277 SHA256 8fc7dc560167b2cb7193e76aca625a152dc19b0ebf49816b78539cbb90d80d02 SHA512 7d3afb327c2e15608194e6ee6110107a0ce082e483788d831d636b2e579472304137373c09a966d8e5c0cd2f830bf2e0ee477c9b5fca7da6ee27fd1498915b9d WHIRLPOOL 58dc258297412b99185f8d284fb4d2ab71ab834aa29e17a9dfb743e93271ae14d517fea2dc886112898f666104300df62b04082c307b3870de4a5d908bf2ae57
+DIST gtkspell3-3.0.4.tar.gz 420762 SHA256 fabf8e670c99c1a91996e0e33fa78b7c023f77efb3e11355cf5aa9bcdc43e4a7 SHA512 907b9321b4608ca13c55c1c3a07a648b2d5eb30f0e4a92dca1c27051af254d4ded2444fef1b941f03a96e29e389d868ee15daad4bd7016239cd0dc54bb0f4abb WHIRLPOOL fd07dfd1fc2b4d449083c6847bf2c69d8f11fce2da6a5198a505e75ce6b14b9bd0c66638b5a15c0f0ff8675914355e6f9bbafbbc2096e786f81870c6ab42c1da
diff --git a/app-text/gtkspell/gtkspell-2.0.16.ebuild b/app-text/gtkspell/gtkspell-2.0.16.ebuild
new file mode 100644
index 000000000000..db9eaae61a1f
--- /dev/null
+++ b/app-text/gtkspell/gtkspell-2.0.16.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Spell checking widget for GTK"
+HOMEPAGE="http://gtkspell.sourceforge.net/"
+# gtkspell doesn't use sourceforge mirroring system it seems.
+SRC_URI="http://${PN}.sourceforge.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="2"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ >=app-text/enchant-1.1.6"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README ) # NEWS file is empty
+
+src_prepare() {
+ # Fix intltoolize broken file, see upstream #577133
+ sed -i -e "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" po/Makefile.in.in || die
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/app-text/gtkspell/gtkspell-3.0.4.ebuild b/app-text/gtkspell/gtkspell-3.0.4.ebuild
new file mode 100644
index 000000000000..c7842a3463bc
--- /dev/null
+++ b/app-text/gtkspell/gtkspell-3.0.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.18"
+
+inherit eutils gnome2 vala
+
+DESCRIPTION="Spell checking widget for GTK"
+HOMEPAGE="http://gtkspell.sourceforge.net/"
+MY_P="${PN}3-${PV}"
+SRC_URI="mirror://sourceforge/project/${PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="3/0"
+KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="+introspection vala"
+
+RDEPEND="
+ >=app-text/enchant-1.1.6
+ app-text/iso-codes
+ dev-libs/glib:2
+ x11-libs/gtk+:3[introspection?]
+ >=x11-libs/pango-1.8.0[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.30 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.17
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
diff --git a/app-text/gtkspell/metadata.xml b/app-text/gtkspell/metadata.xml
new file mode 100644
index 000000000000..d38dbc1104a9
--- /dev/null
+++ b/app-text/gtkspell/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <use>
+ <flag name="vala">Enable bindings for <pkg>dev-lang/vala</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">gtkspell</remote-id>
+ </upstream>
+</pkgmetadata>