summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-08-18 15:04:30 +0200
committerDavid Seifert <soap@gentoo.org>2019-08-18 15:06:00 +0200
commit7bae4800cb2b3a040db34a29b3f380786a8ffca5 (patch)
treee3933b0444d667719c2484c3904800ca2fa0956e /app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild
parentapp-i18n/kcc: Port to EAPI 7 (diff)
downloadgentoo-7bae4800cb2b3a040db34a29b3f380786a8ffca5.tar.gz
gentoo-7bae4800cb2b3a040db34a29b3f380786a8ffca5.tar.bz2
gentoo-7bae4800cb2b3a040db34a29b3f380786a8ffca5.zip
app-text/htmlinc: Port to EAPI 7
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild')
-rw-r--r--app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild31
1 files changed, 12 insertions, 19 deletions
diff --git a/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild b/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild
index 694412759ced..a2d1afc50502 100644
--- a/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild
+++ b/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild
@@ -1,37 +1,30 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="HTML Include System by Ulli Meybohm"
HOMEPAGE="http://www.meybohm.de/"
-SRC_URI="http://meybohm.de/files/${PN}.tar.gz"
+SRC_URI="mirror://gentoo/${PN}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc sparc x86 ~x86-linux ~ppc-macos ~x86-macos"
-IUSE=""
-S=${WORKDIR}/htmlinc
+S="${WORKDIR}/${PN}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-gcc3-gentoo.patch
+ "${FILESDIR}"/${P}-fix-build-system.patch
+)
-src_prepare() {
- epatch "${FILESDIR}"/htmlinc-gcc3-gentoo.patch
- sed -i Makefile \
- -e 's| -o | $(LDFLAGS)&|g' \
- || die "sed Makefile"
-}
-
-src_compile() {
- # This is C++ not C source
- emake \
- CC=$(tc-getCXX) \
- CFLAGS="${CXXFLAGS} -Wall" \
- LDFLAGS="${LDFLAGS}"
+src_configure() {
+ tc-export CXX
+ append-cxxflags -Wall
}
src_install() {
dobin htmlinc
- dodoc README
+ einstalldocs
}