summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-24 14:25:45 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-24 15:02:32 +0200
commit34a06999b1710f4a29bb60295848db3b2455ff0e (patch)
treedd2c97074db669e52baa2b2c2167890530a7fbd7 /app-text/htmlmin/htmlmin-0.1.12-r1.ebuild
parentdev-python/jsmin: enable py3.11 (diff)
downloadgentoo-34a06999b1710f4a29bb60295848db3b2455ff0e.tar.gz
gentoo-34a06999b1710f4a29bb60295848db3b2455ff0e.tar.bz2
gentoo-34a06999b1710f4a29bb60295848db3b2455ff0e.zip
app-text/htmlmin: update EAPI 7 -> 8, enable py3.11, pep517
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-text/htmlmin/htmlmin-0.1.12-r1.ebuild')
-rw-r--r--app-text/htmlmin/htmlmin-0.1.12-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-text/htmlmin/htmlmin-0.1.12-r1.ebuild b/app-text/htmlmin/htmlmin-0.1.12-r1.ebuild
new file mode 100644
index 000000000000..6bc38c00903f
--- /dev/null
+++ b/app-text/htmlmin/htmlmin-0.1.12-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+# upstream doesn't do tags much
+EGIT_COMMIT=220b1d16442eb4b6fafed338ee3b61f698a01e63
+DESCRIPTION="A configurable HTML Minifier with safety features"
+HOMEPAGE="https://github.com/mankyd/htmlmin"
+SRC_URI="
+ https://github.com/mankyd/htmlmin/archive/${EGIT_COMMIT}.tar.gz
+ -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+distutils_enable_tests setup.py
+
+src_prepare() {
+ sed '/prune/d' -i MANIFEST.in || die
+ distutils-r1_src_prepare
+}