summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-02-04 15:59:28 +0100
committerHans de Graaff <graaff@gentoo.org>2017-02-04 16:38:20 +0100
commit0c0dd14e66b6f1e1fa878973c471d38fa85f0fda (patch)
treeb9ba8e0fd4e92438ae297a857b13514232c120ca /app-text/jist/jist-1.5.1-r1.ebuild
parentapp-text/webgen: cleanup (diff)
downloadgentoo-0c0dd14e66b6f1e1fa878973c471d38fa85f0fda.tar.gz
gentoo-0c0dd14e66b6f1e1fa878973c471d38fa85f0fda.tar.bz2
gentoo-0c0dd14e66b6f1e1fa878973c471d38fa85f0fda.zip
app-text/jist: use correct webmock slot; add ruby23
Package-Manager: portage-2.3.3
Diffstat (limited to 'app-text/jist/jist-1.5.1-r1.ebuild')
-rw-r--r--app-text/jist/jist-1.5.1-r1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/app-text/jist/jist-1.5.1-r1.ebuild b/app-text/jist/jist-1.5.1-r1.ebuild
index 7259c8c1bc81..207bec26e3c6 100644
--- a/app-text/jist/jist-1.5.1-r1.ebuild
+++ b/app-text/jist/jist-1.5.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22"
+USE_RUBY="ruby21 ruby22 ruby23"
RUBY_FAKEGEM_RECIPE_TEST="rspec"
RUBY_FAKEGEM_TASK_DOC=""
@@ -21,10 +21,12 @@ IUSE=""
ruby_add_rdepend "dev-ruby/json:*"
-ruby_add_bdepend "test? ( dev-ruby/webmock )"
+ruby_add_bdepend "test? ( dev-ruby/webmock:0 )"
all_ruby_prepare() {
# Avoid failing test (due to webmock version?)
# We did not run any tests previously
rm -f spec/shorten_spec.rb || die
+
+ sed -i -e '1igem "webmock", "~>1.0"' spec/spec_helper.rb || die
}