summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-12-25 17:43:36 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-12-25 17:43:36 +0100
commit6455341aa2191caea132fe3361f1adaf3e2cd5d7 (patch)
tree3db51d5b3fb00bdcc9919057e53acea315718e1a /app-text/krop/krop-0.5.1.ebuild
parentapp-backup/tsm: Use slotted fuse dependency, bug 668054 (diff)
downloadgentoo-6455341aa2191caea132fe3361f1adaf3e2cd5d7.tar.gz
gentoo-6455341aa2191caea132fe3361f1adaf3e2cd5d7.tar.bz2
gentoo-6455341aa2191caea132fe3361f1adaf3e2cd5d7.zip
app-text/krop: Version bump
Closes: https://bugs.gentoo.org/616432 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'app-text/krop/krop-0.5.1.ebuild')
-rw-r--r--app-text/krop/krop-0.5.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-text/krop/krop-0.5.1.ebuild b/app-text/krop/krop-0.5.1.ebuild
new file mode 100644
index 000000000000..21e6ff172169
--- /dev/null
+++ b/app-text/krop/krop-0.5.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit eutils distutils-r1 xdg-utils
+
+DESCRIPTION="A tool to crop PDF files"
+HOMEPAGE="http://arminstraub.com/software/krop"
+SRC_URI="http://arminstraub.com/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/python-poppler-qt5[${PYTHON_USEDEP}]
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+ domenu "${WORKDIR}/${P}/${PN}.desktop"
+}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}