summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/landslide
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/landslide')
-rw-r--r--app-text/landslide/Manifest2
-rw-r--r--app-text/landslide/landslide-1.1.1.ebuild29
-rw-r--r--app-text/landslide/landslide-1.1.3.ebuild32
-rw-r--r--app-text/landslide/metadata.xml10
4 files changed, 73 insertions, 0 deletions
diff --git a/app-text/landslide/Manifest b/app-text/landslide/Manifest
new file mode 100644
index 000000000000..bb85c1303213
--- /dev/null
+++ b/app-text/landslide/Manifest
@@ -0,0 +1,2 @@
+DIST landslide-1.1.1.tar.gz 156083 SHA256 b7860c6eef973b7deb286d8a32b95c4ccab0cb8460844299b36b0d48e9109b02 SHA512 de0ef010589150bf4fa31e9e7fc4b4261ac3cebe91cc8d02745f3ab1f723a811c8d2117cc61a95c5b21c7e34a0fd280640e13a649efb4bc0de7d15e9a2a1548b WHIRLPOOL e12706a23cff2c5785cd8c4192104c7c000c2eb342e58b110c24ad1eada720308a96ddcf94251fd93b4a42e8235ea3e52cbce075d744a8804a5c108fee49d967
+DIST landslide-1.1.3.tar.gz 151003 SHA256 5b0d7c204fef6b06c0997c02c9cb4096b1e7c80fdb548e4ceea9f3b6fa11530f SHA512 2b29c416f8af04c0bf048060e0fe67b0b6a5e293485c5e3f68b9d1ce9d63ef66ca3bc58a96f65705c6918542932ef0a2fa6072b17c4c01cfc1975d283b417152 WHIRLPOOL 1e56326958f41b10e32168fe4b22bf9c383b626c30e58559769c05cf515d3d3395c71ded5acd7f6c49277b5e33ae479cd4fbd570b0cc6a5be32f92c3ff361416
diff --git a/app-text/landslide/landslide-1.1.1.ebuild b/app-text/landslide/landslide-1.1.1.ebuild
new file mode 100644
index 000000000000..90197af752d4
--- /dev/null
+++ b/app-text/landslide/landslide-1.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+
+inherit distutils python vcs-snapshot
+
+DESCRIPTION="Landslide generates a slideshow using the slides that power the html5-slides presentation"
+HOMEPAGE="https://github.com/adamzap/landslide"
+SRC_URI="https://github.com/adamzap/landslide/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-python/docutils
+ dev-python/jinja
+ dev-python/markdown
+ dev-python/pygments"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
diff --git a/app-text/landslide/landslide-1.1.3.ebuild b/app-text/landslide/landslide-1.1.3.ebuild
new file mode 100644
index 000000000000..a7a36c52f420
--- /dev/null
+++ b/app-text/landslide/landslide-1.1.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Landslide generates a slideshow using the slides that power the html5-slides presentation"
+HOMEPAGE="https://github.com/adamzap/landslide"
+SRC_URI="https://github.com/adamzap/landslide/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ "
+
+python_install_all() {
+ use examples && EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/app-text/landslide/metadata.xml b/app-text/landslide/metadata.xml
new file mode 100644
index 000000000000..35121ff9387d
--- /dev/null
+++ b/app-text/landslide/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>naota@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">adamzap/landslide</remote-id>
+ </upstream>
+</pkgmetadata>