summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-02-24 11:00:19 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-02-24 13:31:34 +0100
commitf1e57018491e9e5cb9e4fd87c47026ad0d3d2590 (patch)
treec553cfb0404c7c3544c60bbc9b1b086080637c78 /app-text/lcdf-typetools/lcdf-typetools-2.107.ebuild
parentdev-ros/rqt_robot_steering: bump to 0.5.9 (diff)
downloadgentoo-f1e57018491e9e5cb9e4fd87c47026ad0d3d2590.tar.gz
gentoo-f1e57018491e9e5cb9e4fd87c47026ad0d3d2590.tar.bz2
gentoo-f1e57018491e9e5cb9e4fd87c47026ad0d3d2590.zip
app-text/lcdf-typetools: bump to 2.107
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-text/lcdf-typetools/lcdf-typetools-2.107.ebuild')
-rw-r--r--app-text/lcdf-typetools/lcdf-typetools-2.107.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-text/lcdf-typetools/lcdf-typetools-2.107.ebuild b/app-text/lcdf-typetools/lcdf-typetools-2.107.ebuild
new file mode 100644
index 000000000000..d538c2e96354
--- /dev/null
+++ b/app-text/lcdf-typetools/lcdf-typetools-2.107.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="Font utilities for eg manipulating OTF"
+SRC_URI="http://www.lcdf.org/type/${P}.tar.gz"
+HOMEPAGE="http://www.lcdf.org/type/#typetools"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="+kpathsea"
+
+RDEPEND="kpathsea? ( virtual/tex-base dev-libs/kpathsea )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ use kpathsea && has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
+ econf $(use_with kpathsea)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc NEWS.md README.md ONEWS
+}