summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-08-11 02:35:30 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-08-11 03:13:23 +0200
commitdab1ecdf450876d52b7641706084b40153c904d4 (patch)
tree29387cd871795e3a4a096d22363af6f5ab035b25 /app-text/lesspipe/lesspipe-1.84.ebuild
parentnet-libs/libircclient: add USE=libressl (diff)
downloadgentoo-dab1ecdf450876d52b7641706084b40153c904d4.tar.gz
gentoo-dab1ecdf450876d52b7641706084b40153c904d4.tar.bz2
gentoo-dab1ecdf450876d52b7641706084b40153c904d4.zip
app-text/lesspipe: bump to v1.84
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-text/lesspipe/lesspipe-1.84.ebuild')
-rw-r--r--app-text/lesspipe/lesspipe-1.84.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-text/lesspipe/lesspipe-1.84.ebuild b/app-text/lesspipe/lesspipe-1.84.ebuild
new file mode 100644
index 000000000000..4ecd47310905
--- /dev/null
+++ b/app-text/lesspipe/lesspipe-1.84.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="a preprocessor for less"
+HOMEPAGE="https://github.com/wofr06/lesspipe"
+SRC_URI="https://github.com/wofr06/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ !<sys-apps/less-483-r1"
+
+src_configure() {
+ # Not an autoconf script.
+ ./configure --fixed || die
+}
+
+src_compile() {
+ # Nothing to build.
+ :
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install
+ einstalldocs
+}
+
+pkg_preinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "This package installs 'lesspipe.sh' which is distinct from 'lesspipe'."
+ elog "The latter is the Gentoo-specific version. Make sure to update your"
+ elog "LESSOPEN environment variable if you wish to use this copy."
+ fi
+}