summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-27 03:31:35 +0100
committerSam James <sam@gentoo.org>2022-04-27 03:31:43 +0100
commit4cb673be9dfaf4c9cb570cd3f9cc18d293a38a1b (patch)
tree5f946d450aeb42d51811a237053a1ee04e266af8 /app-text/lesspipe
parentapp-emacs/elixir-mode: undercover tests not available in snapshot (diff)
downloadgentoo-4cb673be9dfaf4c9cb570cd3f9cc18d293a38a1b.tar.gz
gentoo-4cb673be9dfaf4c9cb570cd3f9cc18d293a38a1b.tar.bz2
gentoo-4cb673be9dfaf4c9cb570cd3f9cc18d293a38a1b.zip
app-text/lesspipe: add 2.05
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/lesspipe')
-rw-r--r--app-text/lesspipe/Manifest1
-rw-r--r--app-text/lesspipe/lesspipe-2.05.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-text/lesspipe/Manifest b/app-text/lesspipe/Manifest
index d7d1db048749..3d7322d22af7 100644
--- a/app-text/lesspipe/Manifest
+++ b/app-text/lesspipe/Manifest
@@ -1,2 +1,3 @@
DIST lesspipe-1.91.tar.gz 121965 BLAKE2B 93c169b2b1a81db7e7b569718a43152a8f2b9ea95258047a00ae4940509817a3eb861fdadb6bafc5861c49e805ce910348a57f634bdae57317811ac6fbfc6945 SHA512 d080ceaae019d8885a53c8abb26f4a159b78578f68c2b9a024960aa69509651e3b6638e78bd6e2e57c23d81123d9a3cab167736f253ba4276a3889890d594bd3
DIST lesspipe-2.04.tar.gz 166831 BLAKE2B c33620b1c2714b01a89eaaeaeccfd72e62fd5123270ec84d3e27e914bda8f734758b36ea850126aa1ecd6ab36b9442577ac591024c373bdf6540b95816ed750b SHA512 04312d21c4f45b1630efd597ffafd69fc46ceff1fd5872d296a7811940f9d34da805c4ef4fa543af839de7e8bb4225c6ef5e680e9675eae4f56de669ec975669
+DIST lesspipe-2.05.tar.gz 167135 BLAKE2B 6f54a68a3857fcafa19148ba798d6ac49b2693e547e88a4a4fb6a178768d75ba8ae08e808a9e08aabfe903538bd401e3bd25e22ec240bf3a52365df729d87b9e SHA512 b4220b28fb609060735663067f5a738cae32d12e90efc397db3749e4dcfa7bfc063a4458c1f39b8a43be3b04effdc00a25c4feebd6e9a3b23f0064b879bbb698
diff --git a/app-text/lesspipe/lesspipe-2.05.ebuild b/app-text/lesspipe/lesspipe-2.05.ebuild
new file mode 100644
index 000000000000..dc26753ae52b
--- /dev/null
+++ b/app-text/lesspipe/lesspipe-2.05.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1
+
+DESCRIPTION="A preprocessor for less"
+HOMEPAGE="https://github.com/wofr06/lesspipe"
+SRC_URI="https://github.com/wofr06/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# Please check again on bumps!
+# bug #734896
+RESTRICT="test"
+
+BDEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # Not an autoconf script.
+ ./configure --fixed || die
+}
+
+src_compile() {
+ # Nothing to build (avoids the "all" target)
+ :
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install
+ einstalldocs
+
+ rm -r "${ED}"/etc/bash_completion.d || die
+ newbashcomp less_completion less
+}
+
+pkg_preinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "This package installs 'lesspipe.sh' which is distinct from 'lesspipe'."
+ elog "The latter is the Gentoo-specific version. Make sure to update your"
+ elog "LESSOPEN environment variable if you wish to use this copy."
+ fi
+}