summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-23 03:07:28 +0000
committerSam James <sam@gentoo.org>2022-02-23 03:07:28 +0000
commit61575000f28eb8d8311fcd16400d9b5142435d09 (patch)
tree0e81f91c37fe690f3260effa2ec6e3c5e879889b /app-text/lesspipe
parentnet-libs/libnetfilter_conntrack: drop 1.0.6, 1.0.7 (diff)
downloadgentoo-61575000f28eb8d8311fcd16400d9b5142435d09.tar.gz
gentoo-61575000f28eb8d8311fcd16400d9b5142435d09.tar.bz2
gentoo-61575000f28eb8d8311fcd16400d9b5142435d09.zip
app-text/lesspipe: add 2.03
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/lesspipe')
-rw-r--r--app-text/lesspipe/Manifest1
-rw-r--r--app-text/lesspipe/lesspipe-2.03.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-text/lesspipe/Manifest b/app-text/lesspipe/Manifest
index 6a33ddacded3..af487e36949d 100644
--- a/app-text/lesspipe/Manifest
+++ b/app-text/lesspipe/Manifest
@@ -1,3 +1,4 @@
DIST lesspipe-1.91.tar.gz 121965 BLAKE2B 93c169b2b1a81db7e7b569718a43152a8f2b9ea95258047a00ae4940509817a3eb861fdadb6bafc5861c49e805ce910348a57f634bdae57317811ac6fbfc6945 SHA512 d080ceaae019d8885a53c8abb26f4a159b78578f68c2b9a024960aa69509651e3b6638e78bd6e2e57c23d81123d9a3cab167736f253ba4276a3889890d594bd3
DIST lesspipe-2.01.tar.gz 171601 BLAKE2B 25c65ff0ac97382101fc25f23c52d1d1269d28a30ac472214992fda654946337dfbcd9d9d84e01bbe76902bcdf9c6eb4fdce481b40d2d74632a81d0da4214fa8 SHA512 e050075a43419f735d46314b006ceb16a2255b01a65b192d255a1256178fdca8286473292ef5248c15c8bda305da28275cdedd923c03bc6c601336bb857f2437
DIST lesspipe-2.02.tar.gz 166136 BLAKE2B 337dfbb3e15fb1acd6727fc1d99e8c72895c861babf1c3cd755e77ee31dd94e354c6eb66cd8935b0c7bb6c604b543fd9b269266f1b4abf603585cbb10d46b2de SHA512 7e61199f6b70ae0662d6e75cd15ce1adbb98e6b845f73282e3981bbc58b6ddee6cf2307317e9ebbef285bad57413e18c0f6116cf73491750017667f1af6a0cc6
+DIST lesspipe-2.03.tar.gz 166602 BLAKE2B a90324726f0401417c0f452f489463ac2ef2a710b790ef41c306803dc5c981637530abe034048c0739c1cd698b7901fcdcc074350d1d2a87f848ad5c4f9807ac SHA512 d83b4532f7f1cb58c48e274b34ad1f16c3392b120fbca1d66ff45997e1a28ca8804574e19522745f56344944fa8219ea0457dcb9579bd9b9fe7a8df8a82113f6
diff --git a/app-text/lesspipe/lesspipe-2.03.ebuild b/app-text/lesspipe/lesspipe-2.03.ebuild
new file mode 100644
index 000000000000..9e47976576e2
--- /dev/null
+++ b/app-text/lesspipe/lesspipe-2.03.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A preprocessor for less"
+HOMEPAGE="https://github.com/wofr06/lesspipe"
+SRC_URI="https://github.com/wofr06/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# Please check again on bumps!
+# bug #734896
+RESTRICT="test"
+
+BDEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ !<sys-apps/less-483-r1"
+
+src_configure() {
+ # Not an autoconf script.
+ ./configure --fixed || die
+}
+
+src_compile() {
+ # Nothing to build (avoids the "all" target)
+ :
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install
+ einstalldocs
+}
+
+pkg_preinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "This package installs 'lesspipe.sh' which is distinct from 'lesspipe'."
+ elog "The latter is the Gentoo-specific version. Make sure to update your"
+ elog "LESSOPEN environment variable if you wish to use this copy."
+ fi
+}