summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-10-22 10:54:17 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-11-05 22:00:47 +0100
commit2736f808a7116239e93ae4d11b283c89a42b031a (patch)
treebd1254edd01f1adcb8060168c70c3fe2332a87c7 /app-text/liblangtag/liblangtag-0.6.2.ebuild
parentapp-text/libwps: Drop old (diff)
downloadgentoo-2736f808a7116239e93ae4d11b283c89a42b031a.tar.gz
gentoo-2736f808a7116239e93ae4d11b283c89a42b031a.tar.bz2
gentoo-2736f808a7116239e93ae4d11b283c89a42b031a.zip
app-text/liblangtag: 0.6.2 version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-text/liblangtag/liblangtag-0.6.2.ebuild')
-rw-r--r--app-text/liblangtag/liblangtag-0.6.2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-text/liblangtag/liblangtag-0.6.2.ebuild b/app-text/liblangtag/liblangtag-0.6.2.ebuild
new file mode 100644
index 000000000000..1e36654a23ef
--- /dev/null
+++ b/app-text/liblangtag/liblangtag-0.6.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils xdg-utils
+
+DESCRIPTION="An interface library to access tags for identifying languages"
+HOMEPAGE="https://tagoh.bitbucket.org/liblangtag/"
+SRC_URI="https://bitbucket.org/tagoh/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="|| ( LGPL-3 MPL-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="debug doc introspection static-libs test"
+
+RDEPEND="
+ dev-libs/libxml2
+ introspection? ( dev-libs/gobject-introspection )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ doc? ( dev-util/gtk-doc )
+ introspection? ( dev-libs/gobject-introspection-common )
+ test? ( dev-libs/check )
+"
+
+# Upstream expect liblangtag to be installed when one runs tests...
+RESTRICT="test"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+ if [[ -d docs/html ]]; then
+ rm -r docs/html || die "Failed to remove existing gtk-doc"
+ fi
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable introspection) \
+ $(use_enable static-libs static) \
+ $(use_enable test)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}