summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-01-31 21:23:18 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-01-31 21:32:58 +0100
commitd2b1c4a0f987de3ddc6c6cd15412e2eb5347c4b2 (patch)
treeef0d86d634b427f36a7ddcf161f7fb79d31bd184 /app-text/libmwaw/libmwaw-0.3.10.ebuild
parentprofiles: mask media-video/ffmpeg[nvenc] and unmask it on arches where nvidia... (diff)
downloadgentoo-d2b1c4a0f987de3ddc6c6cd15412e2eb5347c4b2.tar.gz
gentoo-d2b1c4a0f987de3ddc6c6cd15412e2eb5347c4b2.tar.bz2
gentoo-d2b1c4a0f987de3ddc6c6cd15412e2eb5347c4b2.zip
app-text/libmwaw: 0.3.10 version bump
Package-Manager: portage-2.3.3
Diffstat (limited to 'app-text/libmwaw/libmwaw-0.3.10.ebuild')
-rw-r--r--app-text/libmwaw/libmwaw-0.3.10.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-text/libmwaw/libmwaw-0.3.10.ebuild b/app-text/libmwaw/libmwaw-0.3.10.ebuild
new file mode 100644
index 000000000000..c0503c206ed6
--- /dev/null
+++ b/app-text/libmwaw/libmwaw-0.3.10.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGIT_REPO_URI="git://git.code.sf.net/p/libmwaw/libmwaw"
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="Library parsing many pre-OSX MAC text formats"
+HOMEPAGE="https://sourceforge.net/p/libmwaw/wiki/Home/"
+[[ ${PV} == 9999 ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~x86"
+
+IUSE="doc static-libs tools"
+
+RDEPEND="
+ dev-libs/librevenge
+ dev-libs/libxml2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ # zip is hard enabled as the zlib is dep on the rdeps anyway
+ econf \
+ --enable-zip \
+ --disable-werror \
+ --with-sharedptr=c++11 \
+ $(use_with doc docs) \
+ $(use_enable static-libs static) \
+ $(use_enable tools)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}