summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-12-08 12:53:25 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-12-08 16:07:46 +0100
commit1d7159ff3f3b42c5f5fa2363c96140c1c3e273f8 (patch)
tree13f45d94b1e4e486df4b2655003acc8d0b19c115 /app-text/libmwaw/libmwaw-0.3.21.ebuild
parentdev-qt/qtwebengine: 5.15.2_p20211207 snapshot bump (diff)
downloadgentoo-1d7159ff3f3b42c5f5fa2363c96140c1c3e273f8.tar.gz
gentoo-1d7159ff3f3b42c5f5fa2363c96140c1c3e273f8.tar.bz2
gentoo-1d7159ff3f3b42c5f5fa2363c96140c1c3e273f8.zip
app-text/libmwaw: 0.3.21 version bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text/libmwaw/libmwaw-0.3.21.ebuild')
-rw-r--r--app-text/libmwaw/libmwaw-0.3.21.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-text/libmwaw/libmwaw-0.3.21.ebuild b/app-text/libmwaw/libmwaw-0.3.21.ebuild
new file mode 100644
index 000000000000..4c609720e0df
--- /dev/null
+++ b/app-text/libmwaw/libmwaw-0.3.21.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/libmwaw/libmwaw"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Library parsing many pre-OSX MAC text formats"
+HOMEPAGE="https://sourceforge.net/p/libmwaw/wiki/Home/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc tools"
+
+DEPEND="
+ dev-libs/librevenge
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ default
+
+ # Refresh stale libtool, bug #814512
+ eautoreconf
+}
+
+src_configure() {
+ # zip is hard enabled as the zlib is dep on the rdeps anyway
+ local myeconfargs=(
+ --enable-zip
+ --disable-werror
+ $(use_with doc docs)
+ $(use_enable tools)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}