summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-30 21:00:02 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-30 21:07:27 +0100
commit602fe71a29b8a2066ece66d5328e67e72544d549 (patch)
tree29748693fcf7e06a3d9e7d082f34fe7c37de13af /app-text/libqxp/libqxp-0.0.2.ebuild
parentmedia-libs/libcdr: 0.1.5 version bump (diff)
downloadgentoo-602fe71a29b8a2066ece66d5328e67e72544d549.tar.gz
gentoo-602fe71a29b8a2066ece66d5328e67e72544d549.tar.bz2
gentoo-602fe71a29b8a2066ece66d5328e67e72544d549.zip
app-text/libqxp: 0.0.2 version bump
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text/libqxp/libqxp-0.0.2.ebuild')
-rw-r--r--app-text/libqxp/libqxp-0.0.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-text/libqxp/libqxp-0.0.2.ebuild b/app-text/libqxp/libqxp-0.0.2.ebuild
new file mode 100644
index 000000000000..f1095915cd1f
--- /dev/null
+++ b/app-text/libqxp/libqxp-0.0.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Library parsing QuarkXpress documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/${PN}"
+SRC_URI="https://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="debug doc test tools"
+
+RDEPEND="
+ dev-libs/librevenge
+ dev-libs/icu:=
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-weffc
+ $(use_enable debug)
+ $(use_with doc docs)
+ $(use_enable test tests)
+ $(use_enable tools)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}