summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-30 20:42:31 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-30 21:07:26 +0100
commit19cdc2bab27abae136cf7ba4424654cd44b0a338 (patch)
tree6996c8dd8605b5ec9ce2f4087a6985e28898bde0 /app-text/libwpd/libwpd-0.10.3.ebuild
parentapp-text/libetonyek: 0.1.9 version bump (diff)
downloadgentoo-19cdc2bab27abae136cf7ba4424654cd44b0a338.tar.gz
gentoo-19cdc2bab27abae136cf7ba4424654cd44b0a338.tar.bz2
gentoo-19cdc2bab27abae136cf7ba4424654cd44b0a338.zip
app-text/libwpd: 0.10.3 version bump
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text/libwpd/libwpd-0.10.3.ebuild')
-rw-r--r--app-text/libwpd/libwpd-0.10.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-text/libwpd/libwpd-0.10.3.ebuild b/app-text/libwpd/libwpd-0.10.3.ebuild
new file mode 100644
index 000000000000..febfff6725bf
--- /dev/null
+++ b/app-text/libwpd/libwpd-0.10.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="WordPerfect Document import/export library"
+HOMEPAGE="http://libwpd.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0.10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~x86 ~x86-fbsd"
+IUSE="doc +tools"
+
+RDEPEND="dev-libs/librevenge"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ local myeconfargs=(
+ --program-suffix=-${SLOT}
+ --disable-static
+ $(use_with doc docs)
+ $(use_enable tools)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}