summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-13 18:47:03 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-13 21:45:02 +0100
commitd08f21f59b6305ab3239ea43cd979edf405b1a83 (patch)
treec05d9443efddbbb8510c75e348b82853e6cea568 /app-text/libwpg/libwpg-0.3.3.ebuild
parentapp-text/libwpd: Fix build with GCC-4.8 (diff)
downloadgentoo-d08f21f59b6305ab3239ea43cd979edf405b1a83.tar.gz
gentoo-d08f21f59b6305ab3239ea43cd979edf405b1a83.tar.bz2
gentoo-d08f21f59b6305ab3239ea43cd979edf405b1a83.zip
app-text/libwpg: 0.3.3 version bump, EAPI-7 bump
Package-Manager: Portage-2.3.55, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text/libwpg/libwpg-0.3.3.ebuild')
-rw-r--r--app-text/libwpg/libwpg-0.3.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-text/libwpg/libwpg-0.3.3.ebuild b/app-text/libwpg/libwpg-0.3.3.ebuild
new file mode 100644
index 000000000000..d21cc0f2a78d
--- /dev/null
+++ b/app-text/libwpg/libwpg-0.3.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C++ library to read and parse graphics in WPG"
+HOMEPAGE="http://libwpg.sourceforge.net/libwpg.htm"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0.3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ app-text/libwpd:0.10[tools]
+ dev-libs/librevenge
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ local myeconfargs=(
+ --program-suffix=-${SLOT}
+ $(use_with doc docs)
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}