summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/lout/lout-3.38-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/lout/lout-3.38-r1.ebuild')
-rw-r--r--app-text/lout/lout-3.38-r1.ebuild86
1 files changed, 86 insertions, 0 deletions
diff --git a/app-text/lout/lout-3.38-r1.ebuild b/app-text/lout/lout-3.38-r1.ebuild
new file mode 100644
index 000000000000..dc5d98481395
--- /dev/null
+++ b/app-text/lout/lout-3.38-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit eutils toolchain-funcs
+
+IUSE="zlib doc"
+
+DESCRIPTION="high-level language for document formatting"
+HOMEPAGE="http://lout.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lout/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="zlib? ( >=sys-libs/zlib-1.1.4 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ tc-export CC
+ local myconf
+ use zlib && myconf="$myconf PDF_COMPRESSION=1 ZLIB=-lz"
+ emake COPTS="${CFLAGS}" BINDIR="${EPREFIX}"/usr/bin \
+ LOUTLIBDIR="${EPREFIX}"/usr/share/lout \
+ LOUTDOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ MANDIR="${EPREFIX}"/usr/share/man/man1 \
+ ${myconf} lout prg2lout || die "emake prg2lout lout failed"
+}
+
+compile_doc() {
+ #
+ # SYNOPSIS: compile_doc file times
+ #
+
+ einfo "${1}:"
+ # yes, it *is* necessary to run this 6 times...
+ for i in $(seq 1 $(expr $2 - 1)) ; do
+ einfo " pass $i"
+ lout all -o ${docdir}/$1 -e /dev/null
+ done
+ # in the last one, let errors be reported
+ einfo " final pass"
+ lout all -o ${docdir}/$1 || die "final pass failed"
+}
+
+src_install() {
+ local bindir libdir docdir mandir
+ bindir=${ED}usr/bin
+ libdir=${ED}usr/share/lout
+ docdir=${ED}usr/share/doc/${PF}
+ mandir=${ED}usr/share/man/man1
+ export LOUTLIB=${libdir}
+ export PATH="${bindir}:${PATH}"
+
+ mkdir -p ${bindir} ${docdir} ${mandir}
+
+ make BINDIR=${bindir} \
+ LOUTLIBDIR=${libdir} \
+ LOUTDOCDIR=${docdir} \
+ MANDIR=${mandir} \
+ install installdoc installman || die "make install failed"
+
+ lout -x -s "${ED}"usr/share/lout/include/init || die "lout init failed"
+
+ mv ${docdir}/README{,.docs}
+ dodoc README READMEPDF blurb blurb.short whatsnew
+
+ if use doc ; then
+ einfo "building postscript documentation (may take a while)"
+ cd doc/user
+ compile_doc user.ps 6
+ cd ../design
+ compile_doc design.ps 3
+ cd ../expert
+ compile_doc expert.ps 4
+ cd ../slides
+ compile_doc slides.ps 2
+ fi
+}