summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-04-01 22:23:25 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-04-01 22:23:25 -0700
commitfa00c71578e9cbaee502c0589f41891a99b8536b (patch)
tree0ba1878587f0160541952bc04bab01ca8241b43f /app-text/lowdown
parentacct-group/sddm: update DESCRIPTION, typofix (diff)
downloadgentoo-fa00c71578e9cbaee502c0589f41891a99b8536b.tar.gz
gentoo-fa00c71578e9cbaee502c0589f41891a99b8536b.tar.bz2
gentoo-fa00c71578e9cbaee502c0589f41891a99b8536b.zip
app-text/lowdown: add 0.11.2
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-text/lowdown')
-rw-r--r--app-text/lowdown/Manifest1
-rw-r--r--app-text/lowdown/lowdown-0.11.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-text/lowdown/Manifest b/app-text/lowdown/Manifest
index 0a116aa9f30c..126601d3a982 100644
--- a/app-text/lowdown/Manifest
+++ b/app-text/lowdown/Manifest
@@ -1,3 +1,4 @@
DIST lowdown-0.10.0.tar.gz 547397 BLAKE2B 93d87e3aca2466398a625750b928062fbafd26311899e52ddd8264218675e78d30714c920f3331619fcd510a92cc6046401c946f5bd1465d6fd46f26937318ac SHA512 7454e618607628ec0a1649f44f5ec64f8778ecaa151f6aad4984935e297abfe8e84ffc321d3c93cec5d336ff14b6bf9a0ff9054e7363cc58ba708a5b60db9048
DIST lowdown-0.11.1.tar.gz 571320 BLAKE2B 28fe8cb4f164618be602770c602f3ce51c0f0e765fb9869b82cb29c50bdbe0fd92c09c10074d8968108eca59096d7e176531eb56cb2b40f1d9c00a3f944e3b8c SHA512 5a8ca9d731171b97daed7a9095bc4206d2bed9095fa267eb9270782770247743f1a096c5235fd301320418c37a478fbc71552ade105eba0e756ff687835d4efb
+DIST lowdown-0.11.2.tar.gz 576599 BLAKE2B 579a5257a0c37882c1b5269d8196a974b3ac73be146ba424a129c9421091c462769f065350ede1b8437371141c17c24fa5ac4bdc65f393a92835d6e981c5b181 SHA512 f49ba1358a6de9ab792cf1fb7586e0e326b8ba9a153c234079825534cbdc2d10b6af32d5612b11490b97dbd6c0bea10a79752bf1ad7e7d8af871aa20332fed9e
DIST lowdown-0.8.4.tar.gz 520735 BLAKE2B dc66b92f285b186ca83b9fad1cccfef9b395233ef56756e9ea9071b5502cd81dc6ce2d67d7ef265dab8953010af0907cd76125cd4442cfbfc2bcf8c63e097809 SHA512 cd46ead69ed038bf3ccf848b784327d66c78dd8adbc9ae4bfee660b9b1e52844ac8c7ad0377f8f38a3fee0d2e523f979a22d6b547c7964304accef0951cfca34
diff --git a/app-text/lowdown/lowdown-0.11.2.ebuild b/app-text/lowdown/lowdown-0.11.2.ebuild
new file mode 100644
index 000000000000..203b145ffc66
--- /dev/null
+++ b/app-text/lowdown/lowdown-0.11.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs flag-o-matic
+
+MY_PV="VERSION_${PV//./_}"
+DESCRIPTION="Markdown translator producing HTML5, roff documents in the ms and man formats"
+HOMEPAGE="https://kristaps.bsd.lv/lowdown/"
+SRC_URI="https://github.com/kristapsdz/lowdown/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="virtual/libcrypt:="
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/lowdown-0.10.0-pkgconfig-libmd.patch"
+ "${FILESDIR}/lowdown-0.11.1-linking.patch"
+)
+
+src_configure() {
+ append-flags -fPIC
+ tc-export CC AR
+
+ ./configure \
+ PREFIX="/usr" \
+ MANDIR="/usr/share/man" \
+ LDFLAGS="${LDFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ LIBDIR="/usr/$(get_libdir)" \
+ || die "./configure failed"
+}
+
+src_compile() {
+ emake $(usex elibc_musl UTF8_LOCALE=C.UTF-8 '')
+}
+
+src_test() {
+ emake regress
+}