summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoão Santos <joaompssantos@gmail.com>2019-02-18 13:20:40 +0000
committerPatrice Clement <monsieurp@gentoo.org>2019-02-18 20:41:33 +0100
commitec8020da8fc3e87faa8c243d064583c8ab5fa577 (patch)
treecd2294748b53ab1ab0ce665dab1d51a15cafe097 /app-text/master-pdf-editor/master-pdf-editor-5.3.12.ebuild
parentdev-python/texttable: remove old 1.6.0. (diff)
downloadgentoo-ec8020da8fc3e87faa8c243d064583c8ab5fa577.tar.gz
gentoo-ec8020da8fc3e87faa8c243d064583c8ab5fa577.tar.bz2
gentoo-ec8020da8fc3e87faa8c243d064583c8ab5fa577.zip
app-text/master-pdf-editor: version bump to 5.3.12.
Signed-off-by: João Santos <joaompssantos@gmail.com> Package-Manager: Portage-2.3.61, Repoman-2.3.12 Closes: https://github.com/gentoo/gentoo/pull/11094 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-text/master-pdf-editor/master-pdf-editor-5.3.12.ebuild')
-rw-r--r--app-text/master-pdf-editor/master-pdf-editor-5.3.12.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-text/master-pdf-editor/master-pdf-editor-5.3.12.ebuild b/app-text/master-pdf-editor/master-pdf-editor-5.3.12.ebuild
new file mode 100644
index 000000000000..7b474ad5521c
--- /dev/null
+++ b/app-text/master-pdf-editor/master-pdf-editor-5.3.12.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop xdg-utils
+
+DESCRIPTION="A complete solution for viewing and editing PDF files"
+HOMEPAGE="https://code-industry.net/free-pdf-editor/"
+SRC_URI="https://code-industry.net/public/${P}_qt5.amd64.tar.gz"
+
+LICENSE="master-pdf-editor"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+RDEPEND="
+ >=dev-qt/qtcore-5.4.1:5
+ >=dev-qt/qtgui-5.4.1:5
+ >=dev-qt/qtnetwork-5.4.1:5
+ >=dev-qt/qtprintsupport-5.4.1:5
+ >=dev-qt/qtsvg-5.4.1:5
+ >=media-gfx/sane-backends-1.0
+"
+
+QA_PREBUILT="/opt/${PN}/masterpdfeditor5"
+
+S="${WORKDIR}/${PN}-${PV%%.*}"
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r fonts lang stamps templates masterpdfeditor5.png
+
+ exeinto /opt/${PN}
+ doexe masterpdfeditor5
+ dosym ../${PN}/masterpdfeditor5 /opt/bin/masterpdfeditor5
+
+ make_desktop_entry "masterpdfeditor5 %f" \
+ "Master PDF Editor ${PV}" /opt/${PN}/masterpdfeditor5.png \
+ "Office;Graphics;Viewer" \
+ "MimeType=application/pdf;application/x-bzpdf;application/x-gzpdf;\nTerminal=false"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}