summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-02-29 16:27:29 -0500
committerSam James <sam@gentoo.org>2024-02-29 23:57:38 +0000
commita5a2064a14ba3fd844360b3c9f7626f81a410298 (patch)
treef1f0b84804736c2a7e2b09e4782368ba69382bc5 /app-text/mecab/mecab-0.996-r2.ebuild
parentapp-text/mecab: fix totally broken approach to fixing configure CFLAGS (diff)
downloadgentoo-a5a2064a14ba3fd844360b3c9f7626f81a410298.tar.gz
gentoo-a5a2064a14ba3fd844360b3c9f7626f81a410298.tar.bz2
gentoo-a5a2064a14ba3fd844360b3c9f7626f81a410298.zip
app-text/mecab: mark as LTO-unsafe
Closes: https://bugs.gentoo.org/924569 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/mecab/mecab-0.996-r2.ebuild')
-rw-r--r--app-text/mecab/mecab-0.996-r2.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/app-text/mecab/mecab-0.996-r2.ebuild b/app-text/mecab/mecab-0.996-r2.ebuild
index 11c5322f3ecf..7ab1b014a7dd 100644
--- a/app-text/mecab/mecab-0.996-r2.ebuild
+++ b/app-text/mecab/mecab-0.996-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="Yet Another Part-of-Speech and Morphological Analyzer"
HOMEPAGE="https://taku910.github.io/mecab/"
@@ -45,6 +45,11 @@ src_prepare() {
}
src_configure() {
+ # -Werror=odr -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/924569
+ # https://github.com/taku910/mecab/issues/75
+ filter-lto
+
econf \
$(use_enable static-libs static) \
$(use_with unicode charset UTF-8)