summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2017-07-16 01:40:51 +0200
committerThomas Deutschmann <whissi@gentoo.org>2017-07-16 01:49:01 +0200
commit3a8df69639a82439e5cee5f5a01a12201d76a34d (patch)
treee88bf472486d3d9d16b0c4865f19ef56ef6e50ad /app-text/mftrace/mftrace-1.2.19-r1.ebuild
parentmedia-gfx/imagemagick: Drop dependency media-gfx/autotrace on (bug #620806) (diff)
downloadgentoo-3a8df69639a82439e5cee5f5a01a12201d76a34d.tar.gz
gentoo-3a8df69639a82439e5cee5f5a01a12201d76a34d.tar.bz2
gentoo-3a8df69639a82439e5cee5f5a01a12201d76a34d.zip
app-text/mftrace: Drop dependency on media-gfx/autotrace (bug #620804)
Package-Manager: Portage-2.3.5, Repoman-2.3.2 RepoMan-Options: --force
Diffstat (limited to 'app-text/mftrace/mftrace-1.2.19-r1.ebuild')
-rw-r--r--app-text/mftrace/mftrace-1.2.19-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-text/mftrace/mftrace-1.2.19-r1.ebuild b/app-text/mftrace/mftrace-1.2.19-r1.ebuild
new file mode 100644
index 000000000000..fedb8709080c
--- /dev/null
+++ b/app-text/mftrace/mftrace-1.2.19-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 toolchain-funcs
+
+DESCRIPTION="Traces TeX fonts to PFA or PFB fonts (formerly pktrace)"
+HOMEPAGE="http://lilypond.org/mftrace/"
+SRC_URI="http://lilypond.org/downloads/sources/mftrace/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86 ~x86-fbsd"
+# SLOT 1 was used in pktrace ebuild
+SLOT="1"
+IUSE="test truetype"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND=">=app-text/t1utils-1.25
+ media-gfx/potrace
+ truetype? ( media-gfx/fontforge )
+ virtual/latex-base
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ test? ( media-gfx/fontforge )"
+
+src_configure() {
+ tc-export CC
+ econf \
+ --datadir="$(python_get_sitedir)"
+}
+
+src_compile() {
+ emake CFLAGS="-Wall ${CFLAGS}"
+}
+
+src_install () {
+ default
+ python_optimize
+}