summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Roesner <rndxelement@protonmail.com>2021-12-04 00:59:47 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-12-04 10:18:21 +0200
commit59271a38de883bea2a0ebdc0f42dd1ca458b11f0 (patch)
tree664407eeb21a54ff50483f1c84e9c12f75bc2566 /app-text/mupdf/files/mupdf-1.19.0-Makefile.patch
parentmedia-libs/kimageannotator: bump to 0.5.3 (diff)
downloadgentoo-59271a38de883bea2a0ebdc0f42dd1ca458b11f0.tar.gz
gentoo-59271a38de883bea2a0ebdc0f42dd1ca458b11f0.tar.bz2
gentoo-59271a38de883bea2a0ebdc0f42dd1ca458b11f0.zip
app-text/mupdf: bump to 1.19.0
We version bumped the package to mupdf-1.19.0. Several patches were removed because they were fixed upstream. Closes: https://bugs.gentoo.org/827957 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Philipp Roesner <rndxelement@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/23174 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-text/mupdf/files/mupdf-1.19.0-Makefile.patch')
-rw-r--r--app-text/mupdf/files/mupdf-1.19.0-Makefile.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-text/mupdf/files/mupdf-1.19.0-Makefile.patch b/app-text/mupdf/files/mupdf-1.19.0-Makefile.patch
new file mode 100644
index 000000000000..b266655aaeca
--- /dev/null
+++ b/app-text/mupdf/files/mupdf-1.19.0-Makefile.patch
@@ -0,0 +1,37 @@
+diff --git a/Makefile b/Makefile
+index 7fa74b3..e842374 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,7 +3,7 @@
+ -include user.make
+
+ ifndef build
+- build := release
++ build := debug
+ endif
+
+ default: all
+@@ -252,17 +252,19 @@ $(THIRD_GLUT_LIB) : $(THIRD_GLUT_OBJ)
+ $(THREAD_LIB) : $(THREAD_OBJ)
+ $(PKCS7_LIB) : $(PKCS7_OBJ)
+ else
+-MUPDF_LIB = $(OUT)/libmupdf.a
++MUPDF_LIB = libmupdf.so.$(GENTOO_PV)
+ LIBS_TO_INSTALL_IN_LIB = $(MUPDF_LIB) $(THIRD_LIB)
+-THIRD_LIB = $(OUT)/libmupdf-third.a
++THIRD_LIB =
++MUPDF_STATIC = $(OUT)/libmupdf.a
+ ifneq ($(USE_SYSTEM_GLUT),yes)
+ THIRD_GLUT_LIB = $(OUT)/libmupdf-glut.a
+ endif
+ THREAD_LIB = $(OUT)/libmupdf-threads.a
+ PKCS7_LIB = $(OUT)/libmupdf-pkcs7.a
+
+-$(MUPDF_LIB) : $(MUPDF_OBJ)
+-$(THIRD_LIB) : $(THIRD_OBJ)
++$(MUPDF_LIB) : $(MUPDF_OBJ) $(THIRD_OBJ)
++ $(QUIET_LINK) $(CC) $(LDFLAGS) --shared -Wl,-soname -Wl,$(MUPDF_LIB) -o $@ $^ $(THIRD_LIBS) $(LIBS)
++$(MUPDF_STATIC): $(MUPDF_OBJ) $(THIRD_OBJ)
+ $(THIRD_GLUT_LIB) : $(THIRD_GLUT_OBJ)
+ $(THREAD_LIB) : $(THREAD_OBJ)
+ $(PKCS7_LIB) : $(PKCS7_OBJ)