summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/namazu/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/namazu/files')
-rw-r--r--app-text/namazu/files/50namazu-gentoo.el5
-rw-r--r--app-text/namazu/files/namazu-2.0.19-gentoo.patch29
-rw-r--r--app-text/namazu/files/namazu-2.0.21-search.patch56
3 files changed, 90 insertions, 0 deletions
diff --git a/app-text/namazu/files/50namazu-gentoo.el b/app-text/namazu/files/50namazu-gentoo.el
new file mode 100644
index 000000000000..56bbce50af82
--- /dev/null
+++ b/app-text/namazu/files/50namazu-gentoo.el
@@ -0,0 +1,5 @@
+
+;; namazu site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'namazu "namazu" nil t)
diff --git a/app-text/namazu/files/namazu-2.0.19-gentoo.patch b/app-text/namazu/files/namazu-2.0.19-gentoo.patch
new file mode 100644
index 000000000000..6d7f649507bd
--- /dev/null
+++ b/app-text/namazu/files/namazu-2.0.19-gentoo.patch
@@ -0,0 +1,29 @@
+diff -Naur namazu-2.0.19.orig/filter/Makefile.am namazu-2.0.19/filter/Makefile.am
+--- namazu-2.0.19.orig/filter/Makefile.am 2008-05-03 02:07:03.000000000 +0900
++++ namazu-2.0.19/filter/Makefile.am 2009-03-13 01:04:20.000000000 +0900
+@@ -51,9 +51,3 @@
+
+ ETAGS_ARGS = $(filter_DATA) --lang=perl
+ TAGS_DEPENDENCIES = $(filter_DATA)
+-
+-# To remove Windows specific files installed by Namazu 2.0 and/or 2.0.1
+-# and old gfilter.pl (Namazu 2.0.7 or earlier).
+-install-data-local:
+- rm -f $(filterdir)/ole*.pl
+- rm -f $(filterdir)/gfilter.pl
+diff -Naur namazu-2.0.19.orig/filter/Makefile.in namazu-2.0.19/filter/Makefile.in
+--- namazu-2.0.19.orig/filter/Makefile.in 2009-03-12 23:24:48.000000000 +0900
++++ namazu-2.0.19/filter/Makefile.in 2009-03-13 01:05:08.000000000 +0900
+@@ -455,12 +455,6 @@
+ uninstall uninstall-am uninstall-filterDATA uninstall-info-am \
+ uninstall-info-recursive uninstall-recursive
+
+-
+-# To remove Windows specific files installed by Namazu 2.0 and/or 2.0.1
+-# and old gfilter.pl (Namazu 2.0.7 or earlier).
+-install-data-local:
+- rm -f $(filterdir)/ole*.pl
+- rm -f $(filterdir)/gfilter.pl
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT:
diff --git a/app-text/namazu/files/namazu-2.0.21-search.patch b/app-text/namazu/files/namazu-2.0.21-search.patch
new file mode 100644
index 000000000000..6a8e10e8e1a0
--- /dev/null
+++ b/app-text/namazu/files/namazu-2.0.21-search.patch
@@ -0,0 +1,56 @@
+--- a/nmz/search.c 2011-08-05 09:26:47.000000000 +0900
++++ b/nmz/search.c 2011-08-05 09:32:25.000000000 +0900
+@@ -572,7 +572,7 @@
+ {
+ if (*expr == '*' && expr[strlen(expr) - 1] != '*') {
+ /* If suffix match such as '*bar', enforce it into regex */
+- strcpy(expr, expr + 1);
++ memmove(expr, expr + 1, strlen(expr));
+ escape_meta_characters(expr, BUFSIZE * 2);
+ strncat(expr, "$", BUFSIZE * 2 - strlen(expr) - 1);
+ expr[BUFSIZE * 2 - 1] = '\0';
+@@ -584,7 +584,7 @@
+ expr[BUFSIZE * 2 - 1] = '\0';
+ } else if (*expr == '*' && expr[strlen(expr) - 1] == '*') {
+ /* If internal match such as '*foo*', enforce it into regex */
+- strcpy(expr, expr + 1);
++ memmove(expr, expr + 1, strlen(expr));
+ expr[strlen(expr) - 1] = '\0';
+ escape_meta_characters(expr, BUFSIZE * 2);
+ } else if (*expr == '/' && expr[strlen(expr) - 1] == '/') {
+@@ -592,7 +592,7 @@
+ nmz_debug_printf("do REGEX search\n");
+ /* Genuine regex */
+ /* Remove the both of '/' chars at begging and end of string */
+- strcpy(expr, expr + 1);
++ memmove(expr, expr + 1, strlen(expr));
+ expr[strlen(expr) - 1]= '\0';
+ } else {
+ nmz_debug_printf("disabled REGEX search\n");
+@@ -605,7 +605,7 @@
+ || (*expr == '{' && expr[strlen(expr) - 1] == '}'))
+ {
+ /* Delimiters of field search */
+- strcpy(expr, expr + 1);
++ memmove(expr, expr + 1, strlen(expr));
+ expr[strlen(expr) - 1] = '\0';
+ }
+ escape_meta_characters(expr, BUFSIZE * 2);
+@@ -695,7 +695,7 @@
+ delete_beginning_backslash(char *str)
+ {
+ if (*str == '\\') {
+- strcpy(str, str + 1);
++ memmove(str, str + 1, strlen(str));
+ }
+ }
+
+@@ -935,7 +935,7 @@
+ if ((strlen(str) >= 3 && (*str == '"' && str[strlen(str) - 1] == '"'))
+ || (*str == '{' && str[strlen(str) - 1] == '}'))
+ {
+- strcpy(str, str + 1);
++ memmove(str , str + 1, strlen(str));
+ str[strlen(str) - 1]= '\0';
+ }
+ }