summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTill Schäfer <till2.schaefer@uni-dortmund.de>2020-04-13 13:01:13 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-04-21 15:44:48 +0300
commit30bb283628933bb6e0eaadd14e32a37fb4d4c8c1 (patch)
tree5a1cb8f131e24ae33d82c567adca8565b5b36fd1 /app-text/nfoview/nfoview-1.27.1.ebuild
parentsys-block/targetcli-fb: bump to 2.1.51 (diff)
downloadgentoo-30bb283628933bb6e0eaadd14e32a37fb4d4c8c1.tar.gz
gentoo-30bb283628933bb6e0eaadd14e32a37fb4d4c8c1.tar.bz2
gentoo-30bb283628933bb6e0eaadd14e32a37fb4d4c8c1.zip
app-text/nfoview: bump to version 1.27.1
PYTHON_COMPAT added python3_8 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Till Schäfer <till2.schaefer@uni-dortmund.de> Closes: https://github.com/gentoo/gentoo/pull/15329 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-text/nfoview/nfoview-1.27.1.ebuild')
-rw-r--r--app-text/nfoview/nfoview-1.27.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-text/nfoview/nfoview-1.27.1.ebuild b/app-text/nfoview/nfoview-1.27.1.ebuild
new file mode 100644
index 000000000000..cf88d0984798
--- /dev/null
+++ b/app-text/nfoview/nfoview-1.27.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1 xdg-utils
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/otsaloma/nfoview.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/otsaloma/nfoview/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Simple viewer for NFO files, which are ASCII art in the CP437 codepage"
+HOMEPAGE="https://otsaloma.io/nfoview/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE=""
+
+BDEPEND="${PYTHON_DEPS}
+ sys-devel/gettext"
+DEPEND="dev-python/pygobject:3[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ media-fonts/terminus-font"
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}