summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTill Schäfer <till2.schaefer@uni-dortmund.de>2018-04-25 17:28:11 +0200
committerDavid Seifert <soap@gentoo.org>2018-04-26 12:18:46 +0200
commit64b7bf85dca6f37504846754a3f01bb8bc4b482c (patch)
tree53c54c1071ce278b3bfcfac46faaf242c5ba0e26 /app-text/nfoview
parentsci-libs/io_lib: Remove old (diff)
downloadgentoo-64b7bf85dca6f37504846754a3f01bb8bc4b482c.tar.gz
gentoo-64b7bf85dca6f37504846754a3f01bb8bc4b482c.tar.bz2
gentoo-64b7bf85dca6f37504846754a3f01bb8bc4b482c.zip
app-text/nfoview: bump to 1.24
Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/8132
Diffstat (limited to 'app-text/nfoview')
-rw-r--r--app-text/nfoview/Manifest1
-rw-r--r--app-text/nfoview/nfoview-1.24.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-text/nfoview/Manifest b/app-text/nfoview/Manifest
index d5aa3037ccac..c529440fbf62 100644
--- a/app-text/nfoview/Manifest
+++ b/app-text/nfoview/Manifest
@@ -1 +1,2 @@
DIST nfoview-1.23.tar.gz 83337 BLAKE2B d73cd6987bf7929c57e8acf0a24278272ea199bf980756ddb5da9a5eddf7760a8c05f0e48a287ee760d4bf4d2594fb08b43a77cef46d371a746629bf76955e91 SHA512 b94724e130cdf58b911634496c52361d008ebfafab3ac40a76612c4891737d4145596a6badc15fe4228c90c1cd7261e5a892e3e462070ebb55f71332b36345d7
+DIST nfoview-1.24.tar.gz 86037 BLAKE2B 5d565680864f1a73a64d9557e69eda0771dc164f12018ac8964fb1c2225005c1bb881c7b9035c7baed2021838e3a291e52fb5af84cf9c271c046cfddd684270c SHA512 91ad1f9f972b7681655b429c0910475012bd2231e51c6db5659b19fb869779d1de10dadc1d6461fa7d577c051af9b74f1d463543a429e1dca438a4ff17ac2293
diff --git a/app-text/nfoview/nfoview-1.24.ebuild b/app-text/nfoview/nfoview-1.24.ebuild
new file mode 100644
index 000000000000..5b1cf0483c63
--- /dev/null
+++ b/app-text/nfoview/nfoview-1.24.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1 gnome2-utils xdg-utils
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/otsaloma/nfoview.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/otsaloma/nfoview/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="simple viewer for NFO files, which are ASCII art in the CP437 codepage"
+HOMEPAGE="https://otsaloma.io/nfoview/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/pygobject:3[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ media-fonts/terminus-font"
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}