summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-29 03:57:59 +0000
committerSam James <sam@gentoo.org>2021-12-29 03:57:59 +0000
commit873d874069600e85391fd46206665c70751f0beb (patch)
treef02ffdcde9f0b31e4837972ead29409b4b0b9e18 /app-text/ocrad
parentapp-text/epspdf: add 0.6.5 (diff)
downloadgentoo-873d874069600e85391fd46206665c70751f0beb.tar.gz
gentoo-873d874069600e85391fd46206665c70751f0beb.tar.bz2
gentoo-873d874069600e85391fd46206665c70751f0beb.zip
app-text/ocrad: don't call AR directly
Closes: https://bugs.gentoo.org/722474 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/ocrad')
-rw-r--r--app-text/ocrad/ocrad-0.27.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/app-text/ocrad/ocrad-0.27.ebuild b/app-text/ocrad/ocrad-0.27.ebuild
index d7001dd7c77e..be1acd75228b 100644
--- a/app-text/ocrad/ocrad-0.27.ebuild
+++ b/app-text/ocrad/ocrad-0.27.ebuild
@@ -13,9 +13,9 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ppc ppc64 ~sparc x86"
-DEPEND="$(unpacker_src_uri_depends)"
+BDEPEND="$(unpacker_src_uri_depends)"
-DOCS="AUTHORS ChangeLog NEWS README"
+DOCS=( AUTHORS ChangeLog NEWS README )
src_configure() {
# ./configure is not based on autotools
@@ -27,8 +27,13 @@ src_configure() {
--prefix=/usr || die
}
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
src_install() {
default
+
doman doc/${PN}.1
doinfo doc/${PN}.info
}