summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLabbe Corentin <clabbe.montjoie@gmail.com>2018-04-09 12:26:58 +0200
committerJonas Stein <jstein@gentoo.org>2018-04-09 19:51:12 +0200
commit78d1f199c40ba158a02b055b79e07d66d708397f (patch)
tree3eddad2089579ba6644d4d631935b7c4e8e26a82 /app-text/odt2txt/odt2txt-0.5.ebuild
parentkde-misc/kdeconnect: Version bump 1.3.0 (diff)
downloadgentoo-78d1f199c40ba158a02b055b79e07d66d708397f.tar.gz
gentoo-78d1f199c40ba158a02b055b79e07d66d708397f.tar.bz2
gentoo-78d1f199c40ba158a02b055b79e07d66d708397f.zip
app-text/odt2txt: bump to 0.5
Closes: https://bugs.gentoo.org/651548 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-text/odt2txt/odt2txt-0.5.ebuild')
-rw-r--r--app-text/odt2txt/odt2txt-0.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-text/odt2txt/odt2txt-0.5.ebuild b/app-text/odt2txt/odt2txt-0.5.ebuild
new file mode 100644
index 000000000000..71f794e3cdf1
--- /dev/null
+++ b/app-text/odt2txt/odt2txt-0.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A simple converter from OpenDocument Text to plain text"
+HOMEPAGE="http://stosberg.net/odt2txt/"
+SRC_URI="https://github.com/dstosberg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc64 ~sparc ~x86 ~x86-macos"
+IUSE=""
+
+RDEPEND="
+ !app-office/unoconv
+ sys-libs/zlib
+ virtual/libiconv
+"
+DEPEND="${RDEPEND}
+ sys-apps/groff
+"
+PATCHES="${FILESDIR}/${P}-darwin_iconv.patch"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" PREFIX=/usr
+ doman odt2txt.1
+}