summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-05-30 20:51:36 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2021-05-31 01:47:53 +0200
commitd8d52d1eabd4c6961e6ea035fb324379e31a65ce (patch)
tree171c86597173343b4ce755850825045c0b95c243 /app-text/paperwork
parentapp-text/paperwork-backend: 2.0.3 bump (diff)
downloadgentoo-d8d52d1eabd4c6961e6ea035fb324379e31a65ce.tar.gz
gentoo-d8d52d1eabd4c6961e6ea035fb324379e31a65ce.tar.bz2
gentoo-d8d52d1eabd4c6961e6ea035fb324379e31a65ce.zip
app-text/paperwork: 2.0.3 bump
Add back desktop file and icons installation Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'app-text/paperwork')
-rw-r--r--app-text/paperwork/Manifest1
-rw-r--r--app-text/paperwork/files/paperwork-2.0.3-desktop_file.patch12
-rw-r--r--app-text/paperwork/paperwork-2.0.3.ebuild42
3 files changed, 55 insertions, 0 deletions
diff --git a/app-text/paperwork/Manifest b/app-text/paperwork/Manifest
index 7007fcd1a133..7f7bd954b947 100644
--- a/app-text/paperwork/Manifest
+++ b/app-text/paperwork/Manifest
@@ -1 +1,2 @@
DIST paperwork-2.0.2.tar.gz 6222075 BLAKE2B 6dba798ae2b18ba81891c8f9c29e1e2bc8670f24a65e554aa169f05fbf1a89382b9ea24abaa1784da657ac5b9d9d145ffbadaff86ddc3583023f164ffb40c351 SHA512 bde28c167eac5b134b4bdf0f2ac8d93eca4f99c1881ca0edc105c33674114b3a4e3508a1f45048f45ce1c2f6b690a0f765c1b980dbe42c7e1282172f12c3a853
+DIST paperwork-2.0.3.tar.gz 6224520 BLAKE2B 099d76893b0b89e5f7914456ec31346f28335333361a4528efed6ab4c596fa24893d375557d6c1e89f7c83f4a1acac161004138b7e1537aa2f3cb2de0460bcc3 SHA512 d5cf30ef8a6011817947c9878d4defe93a0c82f77562fd707c198d944657db754ba57d703ae3f931ac9e2d7f9f1eb7f9f9093a1d26f25dac0e336b03f9b25ed3
diff --git a/app-text/paperwork/files/paperwork-2.0.3-desktop_file.patch b/app-text/paperwork/files/paperwork-2.0.3-desktop_file.patch
new file mode 100644
index 000000000000..0fbad956449a
--- /dev/null
+++ b/app-text/paperwork/files/paperwork-2.0.3-desktop_file.patch
@@ -0,0 +1,12 @@
+diff -Naur paperwork-2.0.3.orig/src/paperwork_gtk/cmd/install.py paperwork-2.0.3/src/paperwork_gtk/cmd/install.py
+--- paperwork-2.0.3.orig/src/paperwork_gtk/cmd/install.py 2021-02-05 17:46:17.000000000 +0100
++++ paperwork-2.0.3/src/paperwork_gtk/cmd/install.py 2021-05-30 12:26:21.316348652 +0200
+@@ -122,8 +122,6 @@
+ # PDF and all image formats supported by pillow
+ entry.set("MimeType",
+ "application/pdf;"
+- "image/png;"
+- "image/jpeg;"
+ "image/bmp;"
+ "image/gif;"
+ "image/ico;"
diff --git a/app-text/paperwork/paperwork-2.0.3.ebuild b/app-text/paperwork/paperwork-2.0.3.ebuild
new file mode 100644
index 000000000000..b9ec9918ccc6
--- /dev/null
+++ b/app-text/paperwork/paperwork-2.0.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1 xdg
+
+DESCRIPTION="a personal document manager for scanned documents (and PDFs)"
+HOMEPAGE="https://gitlab.gnome.org/World/OpenPaperwork"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="~app-text/openpaperwork-core-${PV}[${PYTHON_USEDEP}]
+ ~app-text/openpaperwork-gtk-${PV}[${PYTHON_USEDEP}]
+ ~app-text/paperwork-backend-${PV}[${PYTHON_USEDEP}]
+ dev-python/libpillowfight[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ >=dev-python/pyocr-0.3.0[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/simplebayes[${PYTHON_USEDEP}]
+ media-libs/libinsane
+ x11-libs/libnotify[introspection]"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-desktop_file.patch )
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ PYTHONPATH="src" "${EPYTHON}" src/paperwork_gtk/main.py install \
+ --icon_base_dir="${ED}"/usr/share/icons \
+ --data_base_dir="${ED}"/usr/share
+}