summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/par
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/par')
-rw-r--r--app-text/par/Manifest1
-rw-r--r--app-text/par/metadata.xml8
-rw-r--r--app-text/par/par-1.52.ebuild31
3 files changed, 40 insertions, 0 deletions
diff --git a/app-text/par/Manifest b/app-text/par/Manifest
new file mode 100644
index 000000000000..d61e19abfd5f
--- /dev/null
+++ b/app-text/par/Manifest
@@ -0,0 +1 @@
+DIST Par152.tar.gz 47999 SHA256 33dcdae905f4b4267b4dc1f3efb032d79705ca8d2122e17efdecfd8162067082 SHA512 f5a46da4b693e6a3d15ccd57e24ee9b0332ebfbcfc88da9ef0731e18932ba6f0adde7691a233264d6361e8903ff7e2263f71885a415c896dc4c45a0d05b1978e WHIRLPOOL 750392d8f4bfccbff6931b221b426b9dfd08568d0e20ea5833672e76baa213992878d690565a973d6e86e5974b89c203418805fe77227a392bb3740103497192
diff --git a/app-text/par/metadata.xml b/app-text/par/metadata.xml
new file mode 100644
index 000000000000..157326a7e891
--- /dev/null
+++ b/app-text/par/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-text/par/par-1.52.ebuild b/app-text/par/par-1.52.ebuild
new file mode 100644
index 000000000000..3ea939c65cda
--- /dev/null
+++ b/app-text/par/par-1.52.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+MY_P="Par${PV/./}"
+DESCRIPTION="a paragraph reformatter, vaguely similar to fmt, but better"
+HOMEPAGE="http://www.nicemice.net/par/"
+SRC_URI="http://www.nicemice.net/par/${MY_P/./}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="!dev-util/par
+ !app-arch/par"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ make -f protoMakefile CC="$(tc-getCC) -c $CFLAGS" \
+ LINK1="$(tc-getCC) $LDFLAGS" || die 'make failed'
+}
+
+src_install() {
+ newbin par par-format || die
+ doman par.1
+ dodoc releasenotes par.doc
+}