summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/passivetex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/passivetex')
-rw-r--r--app-text/passivetex/Manifest1
-rw-r--r--app-text/passivetex/metadata.xml5
-rw-r--r--app-text/passivetex/passivetex-1.25.ebuild33
3 files changed, 39 insertions, 0 deletions
diff --git a/app-text/passivetex/Manifest b/app-text/passivetex/Manifest
new file mode 100644
index 000000000000..e5cb78bc313e
--- /dev/null
+++ b/app-text/passivetex/Manifest
@@ -0,0 +1 @@
+DIST passivetex-1.25.zip 1190258 SHA256 a92669d54ace92b828378fa51f3c7b0faa2e43cf42d7bfbe2506a0a984c1b439 SHA512 083ba4fab9fee327ed3fef5bdc48b415138951432dcb53b1478d1ba16a92bebc1cfc4b8590e2aa647a32c7658124f2aca8160230176c623bbf531e996c43622b WHIRLPOOL 383eec514dbb8ed26b7dd120c07dfe60642a5b0f11df40be83cdc3d0eb76d09e8ec5dfc9f05bd413df45a56f16916c66df694e18eac856c13b34d907a2a2f8a3
diff --git a/app-text/passivetex/metadata.xml b/app-text/passivetex/metadata.xml
new file mode 100644
index 000000000000..ba6a8a8800d5
--- /dev/null
+++ b/app-text/passivetex/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>tex</herd>
+</pkgmetadata>
diff --git a/app-text/passivetex/passivetex-1.25.ebuild b/app-text/passivetex/passivetex-1.25.ebuild
new file mode 100644
index 000000000000..58c4ae3e1178
--- /dev/null
+++ b/app-text/passivetex/passivetex-1.25.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit latex-package
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="A namespace-aware XML parser written in Tex"
+# Taken from: http://www.tei-c.org.uk/Software/passivetex/${PN}.zip
+SRC_URI="mirror://gentoo/${P}.zip"
+HOMEPAGE="http://www.tei-c.org.uk/Software/passivetex/"
+LICENSE="MIT"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+RDEPEND="virtual/latex-base
+ >=dev-tex/xmltex-1.9"
+
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+TEXMF=/usr/share/texmf-site
+
+src_install() {
+
+ insinto ${TEXMF}/tex/xmltex/passivetex
+ doins *.sty *.xmt
+
+ dodoc README.passivetex index.xml
+ dohtml index.html
+}